Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA1000 CLI not allowing input of commands

 
SOLVED
Go to solution
Uwe Zessin
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Firmware upgrades are done via a server.

But before you start, you need to find out if your MSA1000 has one of the early EMUs which had a non-flashable "Flash"-chip - no, I kid you not!
There was a replacement program when the MSA1000 was new - don't know what the current state is.
.
Rob Leadbeater
Honored Contributor
Solution

Re: MSA1000 CLI not allowing input of commands

Hi,

You can't update via the serial console on the early firmware. I just had to update an MSA1000 that was running firmware 2.xx.

The CLI on that version does work properly, however there isn't a "download firmware" command, that you get in the latter releases.

You'll have to connect the MSA up to a server via fibre, then run the MSA Flash utility, available from the download pages here:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=305215&prodTypeId=12169&prodSeriesId=377751&swLang=8&taskId=135&swEnvOID=1005

Cheers,

Rob
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Thanks for all the help chaps. Ive been scowering the interwideweb looking for information about the upgrades and I have noticed that were way behind in regards to the firmware.

You spoke about upgrading your firmwar from version 2.? to the latest one. Did you jump straight to version 7.? or did you have to step up?, if so were did you get the older versions of the firmware. I've managed to find version 6.31 on an old compaq ftp server.

What method did you use for the upgrade? the firmware cd or did you use the windows MSA flash utility?
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Hi,

I went straight from 2.x to 5.20 using the MSA Flash utility, without any problems.

As version 7.00 introduces Active/Active controllers, you might want to avoid this version, until you assess the impact it may have...

Cheers,

Rob
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Were did you find version 5.2?

Cheers
Rob Leadbeater
Honored Contributor

Re: MSA1000 CLI not allowing input of commands

Highlighted
Guy Beukes
Advisor

Re: MSA1000 CLI not allowing input of commands

Thanks Rob,

I was been real stupid. The fimware for version 4.48 is available on the main page. My Apologise. Thanks for the help though. Might be back later on this afternoon after I try to flash this MSA. Hopefully it all goes well, now were did I put that Fiber channel card?