Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA1000 and HPUX 11.0

SOLVED
Go to solution
Joaquin Gil de Vergara
Respected Contributor

MSA1000 and HPUX 11.0

I want to know if it's possible connect a MSA1000 array to a D class hp9000 box.

Server is connected to a SAN to make backups.

HPUX is 11.0 version and idea is connect MSA1000 to SAN

It's possible share MSA1000 with Windows servers too?

Thanks in advance

Joaquin
Teach is the best way to learn
7 REPLIES
Zygmunt Krawczyk
Honored Contributor

Re: MSA1000 and HPUX 11.0

msa1000 requires special release of firmware (4.38) to work with HP-UX. You can't share msa1000 with Windows. msa1000 requires firmware 4.32 to work with Windows.

You can try to connect msa1000 to D-Class/HP-UX 11.00. It should work.

Regards,
Zygmunt
Joaquin Gil de Vergara
Respected Contributor

Re: MSA1000 and HPUX 11.0

Thank you Zygmunt

I suppose that this can work, but I need to be sure that this is right... you know anybody that has this cnfiguration?


Thanks again
Teach is the best way to learn
Uwe Zessin
Honored Contributor

Re: MSA1000 and HPUX 11.0

This page:
http://h18000.www1.hp.com/products/storageworks/softwaredrivers/msa1000/msa1k_intel.html

is mentioning HP-UX 11.11 and 11.23.

I read that as there is no support for 11.0. If it works for you - great. If it does not work - well, I am afraid you are on your own. Sorry.
.
John Kufrovich
Honored Contributor

Re: MSA1000 and HPUX 11.0

Hey Joaquin

Zygmunt is correct on the MSA FW versions. But this will be the case for only another month. There will be a new FW version that incorporates both OS's. So, you will be able to mix both machines on the MSA.
The only caveat is still no failover support for the HPUX machine.

Also, when that time comes, new FW release, please use SSP and set the correct profile. Window Servers have a habit of claiming any and all luns.

Zygmunt Krawczyk
Honored Contributor
Solution

Re: MSA1000 and HPUX 11.0

Hi Joaquin,

"MSA1000 Firmware Upgrade v4.38 is the current version of firmware to be used exclusively for support of specific Itanium and RISC based Integrity servers operating with HP-UX. 11.11 and 11.23. Support is only for an MSA1000 in a single controller configuration in a homogeneous environment. The firmware that ships with the MSA1000 must be replaced with this firmware version. Choose the offline or online version. Both have the identical files"

Read the doc:
"hp StorageWorks Modular Smart Array 1000
Configuration Procedures - for HP-UX"
http://h200006.www2.hp.com/bc/docs/support/SupportManual/c00096723/c00096723.pdf

msa1000 is fully supported on HP-UX 11i v1 (11.11) and 11i v2 (11.23).
If you want to use msa1000 on HP-UX 11.0, you must upgrade msa1000 firmware to HP-UX version using ProLiant server with FC card.

The following software components will not work on HP-UX 11.0
1) EMS diagnostics will no recognize msa1000, so the array will not be monitored.
This functionality is not required for normal operation of the array.

2) SCU (SCSI utility). SCU is needed only for querying of various array information.
It is not required for normal operation of the array.

Configuration of the array should be done using CLI via serial cable and terminal (or PC).
Read the doc:
"hp StorageWorks Modular Smart Array 1000/1500 cs
Command Line Interface"
http://h200006.www2.hp.com/bc/docs/support/SupportManual/c00149849/c00149849.pdf

After configuring, you should be able to see the array LUNs from HP-UX 11.0

Regards,
Zygmunt
Joaquin Gil de Vergara
Respected Contributor

Re: MSA1000 and HPUX 11.0

Hello Zygmunt

Where do you read this?

I don't read anything about HPUX 11.0

Installation instructions from firmware v4.38 says that this only can be done from HPUX

http://h18006.www1.hp.com/products/storageworks/softwaredrivers/msa1000/msa1k_intel.html#hpux

Thanks for your help
Teach is the best way to learn
Zygmunt Krawczyk
Honored Contributor

Re: MSA1000 and HPUX 11.0

Read carefully the installation instruction
"hp StorageWorks Modular Smart Array 1000
Configuration Procedures - for HP-UX"
http://h200006.www2.hp.com/bc/docs/support/SupportManual/c00096723/c00096723.pdf

Firmware upgrade to version 4.38 (HP-UX version) can be done from HP-UX system
in one case only - if you have fabric connection to array (via FC switch).

In all other cases firmware upgrade must be done from ProLiant (PC) system,
as described on page 7.

Yes, of course, msa1000 does not support HP-UX 11.0, so you can't read anything
about 11.0 in installation instruction. But "not supported" is not equal "not working".

Regards,
Zygmunt