Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA1000 error "incorrect function " in the windows disk manager

MAH_2
Regular Advisor

MSA1000 error "incorrect function " in the windows disk manager

I am using MSA1000. connected to the windows 2008 R2 server DL380G7. I have 2 HBA with single port. Only one port is connected to the switch. Both the controller port from the HUB of the MSA is connected to the same switch. I have created the LUN and presented to the windows 2008 R2. I can see the new LUN. When I start formating or initialzing the LUN, I am getting error "incorrect function". I am using Microsoft MPIO. If I disconnect the any one of the controller from the swich, I can work without any error. If I recnnect the controller, then the LUN will go offline.


Why this issue is happening? Pls help if anybody can help?
3 REPLIES
Johan Guldmyr
Honored Contributor

Re: MSA1000 error "incorrect function " in the windows disk manager

MAH_2
Regular Advisor

Re: MSA1000 error "incorrect function " in the windows disk manager

Thanks for reply. I have applied the link you have given. But that is only a DSM manager.
I have upgraded the firmaware (A/A). Then the problem is solved.
Exrace
Occasional Visitor

Re: MSA1000 error "incorrect function " in the windows disk manager

I am on 2008 r2 on a older dl380 g4 with a msa1000.

What firmware ver was used that worked in this case?

This array is not prod yet so I have no worries of losing configs


MAH_2 wrote:
Thanks for reply. I have applied the link you have given. But that is only a DSM manager.
I have upgraded the firmaware (A/A). Then the problem is solved.