Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

MSA500 & RHEL6/CentOS6 Crash

mpapet
Advisor

MSA500 & RHEL6/CentOS6 Crash

I tried posting this in the general Linux forum and got no response.

 

I have a pair of Dl380 G3's, an MSA 500 as shared storage with Cent0S 6.3 installed on either host with the end goal being to have a clustered iscsi disk presented on /dev/cciss/c0d1 and some other clustered apps on /dev/cciss/c0d2p$whatever

 

The MSA 500 has two arrays:

#1 Raid 5 109GB plus a hot spare /dev/cciss/c0d1

#2 Raid 1 33GB 2 disks  /dev/cciss/c0d2p5 as extended or /dev/cciss/c0d2p2 as primary

 

I can partition the disks okay.  However, I cannot create an ext3 file system on /dev/cciss/c0d2p2 or /dev/cciss/c0d2p5  Kernel crash and never returns without a hard reset.  No error logged either.

 

 mkfs.ext3 -L apps /dev/cciss/c0d2p5
mke2fs 1.41.12 (17-May-2010)
Filesystem label=apps
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
2223872 inodes, 8889953 blocks
444497 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=0
272 block groups
32768 blocks per group, 32768 fragments per group
8176 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
        4096000, 7962624

Writing inode tables:  49/272
-----CRASH---

 

I've tried it with both hosts running, either one or the other host running, restarting the MSA 500, a new array in different slots, live CD's with different kernel versions and I get the same result.  Crash at 49/272.  I've tried the in-kernel module, and HP's rpm download.  Same effect.

 

Am I missing something that brings the whole system down?

 

3 REPLIES
Johan Guldmyr
Honored Contributor

Re: MSA500 & RHEL6/CentOS6 Crash

If you're going to have two servers accessing the same filesystem, you want to use a clustered file system.

 

http://en.wikipedia.org/wiki/Clustered_file_system

 

http://en.wikipedia.org/wiki/List_of_file_systems#Shared_disk_file_systems

 

Doesn't explain why it crashes when you do it with only one server on though..

mpapet
Advisor

Re: MSA500 & RHEL6/CentOS6 Crash

The end goal was to build a modern active/passive cluster so the partition will only be active on one node at a time.

 

It just doesn't work at all.  I went backwards with CentOS/Fedora versions 5.x and any attempt to do anything to the partition crashes the OS.  No log of the crash either.  What a waste of time.

 

Debian Stable works.  That is **completely** frustrating because HP has no system insight manager package for Debian.   

 

Posted a bug to CentOS a long time ago and have no response.   Frustrating pretty much sums it up.

Johan Guldmyr
Honored Contributor

Re: MSA500 & RHEL6/CentOS6 Crash

Perhaps the kernel crash is only visible on the console?