Disk Enclosures
Showing results for 
Search instead for 
Did you mean: 

Migrate a NTFS LUN

David Rozé
Occasional Visitor

Migrate a NTFS LUN

I have 2 HP DL360 running Windows 2003 server x64, connected to a MSA2012i.
The subject has come up many times there is no way to access a NTFS partition from 2 servers simultaneously like in a cluster mode.

However, I'd like to dismount the partition on the first server and remount it on the second.
I disabled disk write caching, and make a 'mountvol E: /D' to remove it before reassigning a letter to the drive on the second server.

This works pretty well but the very last changes do not get written to the disk and are missing (NTFS permissions, and some files occasionally), even though disk write caching is disabled.
NTFS cache seems to be the root cause of the problem. Is there a way to flush NTFS cache before disconnecting the drive? I tried the tool 'sync' from http://technet.microsoft.com/en-us/sysinternals/bb897438.aspx but this seems useless! I find it hard to believe it's not possible to unmount a partition properly unless rebooting the server. Any Unix system can do this!
Other ways I was thinking of: Are there any drivers out there that make the disk behave as a removable media (or registry settings) so all data get written directly on to the disk? Or maybe there are HP tools or utilities to disconnect the LUN properly I'm not aware of?
Other solutions?

Thanks for your replies
Niels Vejrup Pedersen
Respected Contributor

Re: Migrate a NTFS LUN


Have you tried making the disk offline in disk manager from the node that has the disk online ?

Then rescan on second host.

David Rozé
Occasional Visitor

Re: Migrate a NTFS LUN

I did and you're right: mountvol is part of the problem. I remove the drive letter with diskpart, which is the same as in disk manager. This works for changes made on the server but on the shares from the network (even though I deleted open sessions and stopped the service 'server'). It's still losing some of the permissions.
Running further tests, my only workaround is to launch a checkdisk after mapping the drive on the second server. It gets all the permissions back pretty quickly. 100%