Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem Adding New Disks

Andrew Kaplan
Super Advisor

Problem Adding New Disks

We are in the process of adding four 73GB disks to our L class system running HP-UX 11. When we go through the motion of binding the LUN via SAM we notice that two of the disks are showing up with capacities of 64GB while the other two have 68GB. We are losing approximately 16GB of diskspace because of this. The array controllers are FC-60 class while the disk enclosures are SC-10. We have several other disk stripes that use 73 GB disks and they do not have this same problem. We tried replacing what we thought was the offending disk with another one, but the problem continued to appear. Has anyone seen this and know what is the cause? Thanks.
A Journey In The Quest Of Knowledge
2 REPLIES
Hein van den Heuvel
Honored Contributor

Re: Problem Adding New Disks


Are those new luns added to an existing VG?
What is teh "PE Size (Mbytes)" for that group, or the new group (vgdisplay -v /dev/vg...)
What is the "Max PE". The default is just 1016, severely limiting maximum size. The maximum maximum is 64K (65536). Multiplying this with the default PE size (4MB) gives 256 GB of addressabel space... which roughly corresponds with the observered disk sizes.
Check out 'man vg_create'.

If you need better help, please provide better information. Perhaps show us how/where you observerd the size? Attach a text file wtih some vgdisplay -v output?
Perhpas soem diskinfo output?

Hth,
Hein.
Andrew Kaplan
Super Advisor

Re: Problem Adding New Disks

Hi there --

I did some further investigating, and it appears to be a firmware issue on the hard drives coupled with their being approximately three years old. Thanks for the help anyway.
A Journey In The Quest Of Knowledge