Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

RAID 5 rebuild error

GFHTech51
Occasional Visitor

RAID 5 rebuild error

I have a Proliant DL380 Gen4 with SmartArray 6i and SmartArray 6400.  There are four 72GB Ultra320 drives in a RAID 5 array with one logical volume and two 300GB Ultra320 drives in a RAID 0+1 array with one logical volume on the SmartArray 6i and an external drive shelf with fourteen 146GB drives on the SmartArray 6400.  The server is running Microsoft Windows Server 2003 R2.

 

Several weeks ago, one of the 72GB drives failed (HDD #0) and was replaced.  The rebuild completed with no errors.  About two weeks later a second 72GB drive failed (HDD #2) and was replaced.  The rebuild initiated but failed when a bad block was encounter on HDD #0.  With the new 72GB drive in HDD #2, system performance is unbelievably slow (45 minutes to just logon to the server).  I shut down the server, pulled HDD #2, and rebooted in interim recovery mode with only three drives in the RAID 5 array.  The performance is nearly normal but, of course, there is no fault tolerance for the RAID 5 array.

 

The logical volume on the RAID 5 array is partitioned into two partitions (drive C: and D:).  Drive C: is the system volume and drive D: is the SQL database volume.  I tried to Ghost an image of the logical volume of the RAID 5 array to the RAID 0+1 array.  It got only part way and just stopped.  I could see intermittent disk activity on HDD #0 but the Ghost application never reported an error and was unresponsive.  The last file written to the Ghost image was "26000 unnamed MFT".  I haven't tried any switches for Ghost other than -IB to copy the boot sector.  I'm not sure that Ghost is seeing the bad block so the -FRO switch may not improve things.  Also, use of the -FRO switch seems to be for disk cloning, which I'm not doing.

 

Does anyone have any thoughts on how to proceed next?  Is there something I can do at the controller level.  I have a feeling that running a CHKDSK /f/r won't find or fix anything.  We do nightly backups of the entire system without any errors being reported.  Unfortunately, we could not afford the DR option so recovery of the system partition from backups is laborious with only a slim chance of success.  I tried Microsoft Backup as an option but the Volume Shadowing service failed to stay running.