Disk Enclosures
Showing results for 
Search instead for 
Did you mean: 

RAID LUN size limit?

Go to solution
David Timberline
Occasional Advisor

RAID LUN size limit?

Hello experts!
Long-time ITRC user, first-time poster. Hoping you all can help with a perplexing problem.

Have a new rx4640 Integrity server with 2 Smart Array 6402 controllers hooked up to two MSA 30s, each with 11 146GB disks. Can use saconfig to set up LUNs with no problem. However, none of the LUNs seem to be able to get over 255 GB. Have tried any number of disks but always hit 255GB limit.

Specs. say 2TB logical drive possible -- why can't I get one? Is this something stupid? Firmware version is 2.58. Any help would be most appreciated!

Example sautil output:
---- CONTROLLER INFORMATION --------------------------------------------------

Controller Product Number........... A9890A
Controller Product Name............. HP PCI-X SmartArray 6402
Hardware Path....................... 0/2/1/0/4/0
Serial Number....................... P57820TXQSW04E
Device File......................... /dev/ciss4
Hardware Revision................... 'B'
Boot Block Revision................. 5.76
Firmware Revision (running)......... 2.58
Firmware Revision (in ROM).......... 2.58
Firmware Revision (inactive)........ 2.58
# of Logical Drives................. 1
# of Physical Disks Configured...... 3
# of Physical Disks Detected........ 11
Logical Drive Rebuild Priority...... 118 (high)
Array Capacity Expansion Priority... 0 (low)
Auto-Fail Missing Disks at Boot..... enabled
SCSI Transfer Detection Mode........ Auto Detect

---- ARRAY ACCELERATOR (CACHE) INFORMATION -----------------------------------

Array Accelerator Board Present?.... yes
Cache Configuration Status.......... cache enabled
Cache Ratio......................... 50% Read / 50% Write
Total Cache Size (MB)............... 128
Read Cache........................ 064
nutmeg: # swlist |grep RAID
RAID-01 B.11.23.0606 RAID SA; Supptd HW=A7143A/A9890A/A9891A
nutmeg: # saconfig /dev/ciss4|more

******************** SmartArray RAID Controller /dev/ciss4 ********************

Auto-Fail Missing Disks at Boot = enabled
Cache Configuration Status = cache enabled
Cache Ratio = 50% Read / 50% Write

---------- PHYSICAL DRIVES ----------

Location Ch ID Size Status

External 1 0 146.8 GB OK
External 1 1 146.8 GB OK
External 1 2 146.8 GB OK
External 1 3 146.8 GB UNASSIGNED
External 1 4 146.8 GB UNASSIGNED
External 2 0 146.8 GB UNASSIGNED
External 2 1 146.8 GB UNASSIGNED
External 2 2 146.8 GB UNASSIGNED
External 2 3 146.8 GB UNASSIGNED
External 2 4 146.8 GB UNASSIGNED
External 2 8 146.8 GB UNASSIGNED

---------- LOGICAL DRIVE 0 ----------

Device File = c4t0d0
RAID Level = 5
Size = 261116 MB
Stripe Size = 16 KB
Status = OK
Basil Vizgin
Honored Contributor

Re: RAID LUN size limit?

In Windows environment this issue was resolved in one of the latest ACU.
David Timberline
Occasional Advisor

Re: RAID LUN size limit?

Oops. Should have specified: I'm on HP-UX 11.23.
Steven Clementi
Honored Contributor

Re: RAID LUN size limit?


Are you sure all the disks are assigned to the Array? It looke like you only have 3 disks assigned to the Array. 3*146 would give you about 260GB Available for RAID 5. (Sounds a little off, I know, shoule be more like 270GB).

Steven Clementi
HP Master ASE, Storage and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5)
NPP3 (Nutanix Platform Professional)
kris rombauts
Honored Contributor

Re: RAID LUN size limit?


did you tried using the ORCA utility, this is the ROM based utility on the SmartArray card, the one you can enter with F8 when the server boots ?
If you can't get to it, do a reconnect -r from the EFI shell and you should see the SmartArray loading again with all other cards that have a ROM.

Just give it a try and see if that allows you to get to a bigger array/logical drive.
If it can, then their is a issue with sautil/sacofnig i guess and you should talk to HP support.

Don't think this is a F/W issue but you can always update to the latest supported one which is V2.62 for UX, available here:



David Timberline
Occasional Advisor

Re: RAID LUN size limit?

The size stays consistent no matter how many drives are assigned, from 3 (minimum for RAID 5) up to 10.

What am I supposed to see with the ORCA utility? I've rebooted 4 times now and I don't seem to be able to get it to do much of anything. Once in EFI and having done a reconnect -r, I get the following:

Scsi(Pun1,Lun0) HP 36.4GST336754LC HPC3 (320 MBytes/sec)
Scsi(Pun0,Lun0) HP 36.4GST336754LC HPC3 (320 MBytes/sec)
HP Smart Array 6400-128 Controller (version 2.58) 1 Logical Drive

Press to run the Option ROM Configuration for Arrays Utility
Press to skip configuration and continue

Pressing F8 repeatedly gets me nothing. Eventually I see this:
1785-Drive Array Not Configured
Run Smart Array Configuration Utilityntinue

On a subsequent try (telnet-ed into the MP), I sent a Toggle Scrollback (the "hand" in Hummingbird) instead of F8 and eventually got this:
ReconnectController(0,0,0) : Status = Success

Whatever has happened does not change the behavior though. Blew away LUN config and tried again with 4 disks and still stuck at 261,116 MB. Any thoughts?

I have a SR logged with HP now as well.
kris rombauts
Honored Contributor

Re: RAID LUN size limit?


try ESC 8 to send the F8 to enter the ORCA, utility it depends on the terminal emulator you're using.

In ORCA you can create arrays/logical drives
it's a simple/basic tool available in the ROM of the controller. This should simply work and allow you to create the array you want as it is OS independent.

If still no luck, try the Putty emulator and their the ESC 8 works to send F8 to the controller. It is available on the SmartSetup cd's and attached here.


David Timberline
Occasional Advisor

Re: RAID LUN size limit?

Thanks for your help, Kris. The solution ended up being upgrading the RAID software. I upgraded from
RAID-01 B.11.23.0606 RAID SA; Supptd HW=A7143A/A9890A/A9891A

up to
RAID-01 B.11.23.0609 RAID SA; Supptd HW=A7143A/A9890A/A9891A

and am now able to create big fat LUNs.
Thanks again.
David Timberline
Occasional Advisor

Re: RAID LUN size limit?

Upgrading RAID software seems to have resolved the problem.