Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

RAID5 problem w/ SmartArray 5i on a DL380G3

Fussel
Advisor

RAID5 problem w/ SmartArray 5i on a DL380G3

Hi,

I have a problem with a DL380G3 of a customer (2x3,06, 2 GB, 6x72,8 GB in a RAID5 w/ hotspare on a SmartArray 5i w/ battery backup, WIN2K server).

I see this server about once a week. Usually, of course, drive IDs 0 to 4 show green, ID5 (the hotspare) shows no light.

This weekend, HD ID2 showed red, ID5 showed green, indicating the hotspare was used. I verified this with ADU and the Windows event viewer.

I then changed ID 2 to another (known good) drive. Windows event viewer showed "rebuilding", the drive LEDs confirmed this.

Later, event viewer showed "status changed" from "rebuilding" to "ready for rebuild" and told about a hard read error on ID4. Now, only IDs 0, 1, 3, 4 showed green, IDs 2 and 5 showed no light.

I then restarted the server (after all, it was weekend). The controller BIOS said "previous rebuild was aborted". F1 worked, it tried to rebuild again. But to no avail, another change to "ready for rebuild" later on.

I tried to reboot the server again with the same results.

The ADU report confirms the read error on ID4. SCSI Stat 02 (CHECK CONDITION), CAM Stat 04 (CAM_REQ_CMP_ERR), Sense key 03 (MEDIUM ERROR), Sense code 11 qual 0 (UNRECOVERED READ ERROR), Op 28 (READ), always the same sector (01919fbc).

What can I do to rebuild the array?? Sadly. there is no real backup. I did an Acronis backup yesterday, but I'd rather not rely on that. The production data are safe, of course (copied nightly to a NetWare server and backed up to tape), but the installation of all the programs and databases took several days with external help.

Would it help to try a SmartArray 5300 or 6400? If so, can they rebuild an array without Windows starting up (which I'd rather not do with a different controller in the system)?

Any help greatly appreciated. Thanks in advance.

Fussel

1 REPLY
gregersenj
Honored Contributor

Re: RAID5 problem w/ SmartArray 5i on a DL380G3

Ohh, you and your customer has got problem.

You've got a multible disk failure.

If the rebuild to the spare was succesfull, then you can replace ID4.

If the rebuild to the spare was failed,
then it's all over. = New installation and restore from backup.

This is a HDD error, not controller.

BR
/jag