Disk Enclosures
Showing results for 
Search instead for 
Did you mean: 

Recover array on SA3200(DL760)

Occasional Contributor

Recover array on SA3200(DL760)

need some help to recover a broken Raid5 array attached to the onboard SA3200 in a Compaq Proliant 760.
I was in the process to extend an existing array from 4*9GB to 4*36GB. Replacing the first drive went successful, the second drive also. Replacing the 3rd drive, the rebuild process failed at 14% with the following error:

"Recovery of logical drive 1 on the Compaq Integrated Smart Array Controller was aborted. An unrecoverable read error occurred while rebuilding the hard disk drive with drive ID 18. The hard disk drive reporting the error is drive ID 17."

I tried another disk as 3rd device, same error, seems to be a read error on one of the 3 devices.

So far, there is a problem now: The system is up and running, but I can't neither rebuild the array, nor replace one of the running disks.
Each time I re-insert a disk for 3rd drive, the recovery process starts, and then fails like above. After that, I don't have an option in the ACU to reconfigure the array, can only delete the array :(

Is there an option, to either:
- Recover the array with the bad blocks?
- Reconfigure the array to a Raid0, or, better, a Raid10 using the existing array, and the newly inserted disk? Since the original array has a capacity of 27GB (4*9 R5), should be possible to mirror to a 36 GB drive, drop the failed array, and build a new one with new disks. Not necessary to to this online, but without data loss ;)
Does the CLI version of the ACU has more options than the GUI? Any other options? There is a SA 5304 controller in the machine too, with an attached external array, maybe this provides some more options?
Any help would be appreciated!