Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

SecurePath 3.0a for linux connecting to EVA110

ecorban
Frequent Advisor

SecurePath 3.0a for linux connecting to EVA110


Hi,

We are having problems when using SP 3.0a on a RH adv server with the correct smp kernel.
After the SP is installed it picks up the eva storage, spagent has started, but when we run the spmgr display command the command just aborts, see below

root@cp091007 log]# spmgr display
Server: cp091007 Report Created: Wed, Oct 15 17:29:15 2003
Command: spmgr display
Aborted
[root@cp091007 log]#


Also, when i check i dont see any devices in the /dev/spdev, however i do see
scsi(1): Topology - (F_Port), Host Loop address 0xffff
scsi0 : QLogic QLA2312 PCI to Fibre Channel Host Adapter: bus 7 device 5 irq 15
Firmware version: 3.01.18, Driver version 6.04.01
scsi1 : QLogic QLA2312 PCI to Fibre Channel Host Adapter: bus 7 device 6 irq 10
Firmware version: 3.01.18, Driver version 6.04.01
blk: queue c17fa218, I/O limit 4095Mb (mask 0xffffffff)
scsi: unknown type 12
Vendor: COMPAQ Model: HSV110 (C)COMPAQ Rev: 3010
Type: Unknown ANSI SCSI revision: 02
blk: queue c17fa418, I/O limit 4095Mb (mask 0xffffffff)
scsi: unknown type 12
Vendor: COMPAQ Model: HSV110 (C)COMPAQ Rev: 3010
Type: Unknown ANSI SCSI revision: 02
blk: queue c17fa018, I/O limit 4095Mb (mask 0xffffffff)
scsi(0:0:0:0): Enabled tagged queuing, queue depth 16.
scsi(0:0:1:0): Enabled tagged queuing, queue depth 16.
blk: queue c17fa018, I/O limit 4095Mb (mask 0xffffffff)
scsi: unknown type 12
Vendor: COMPAQ Model: HSV110 (C)COMPAQ Rev: 3010
Type: Unknown ANSI SCSI revision: 02
blk: queue c1bb9418, I/O limit 4095Mb (mask 0xffffffff)
scsi: unknown type 12
Vendor: COMPAQ Model: HSV110 (C)COMPAQ Rev: 3010
Type: Unknown ANSI SCSI revision: 02
blk: queue c1bb9218, I/O limit 4095Mb (mask 0xffffffff)
scsi(1:0:0:0): Enabled tagged queuing, queue depth 16.
scsi(1:0:1:0): Enabled tagged queuing, queue depth 16.

and

resize_dma_pool: unknown device type 12
resize_dma_pool: unknown device type 12
resize_dma_pool: unknown device type 12
resize_dma_pool: unknown device type 12
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 12
Attached scsi generic sg1 at scsi0, channel 0, id 1, lun 0, type 12
Attached scsi generic sg2 at scsi1, channel 0, id 0, lun 0, type 12
Attached scsi generic sg3 at scsi1, channel 0, id 1, lun 0, type 12

Now, why did it not create the new spdev devices, why do i only see sg scisi disk devices? Our setup is a brocade switch 3900 (2GB), one hba0 ql2340 connected to one switch zoned with 2 HSV ports and the other hba1 zoned on another switch with e other HSV ports. The setup is ok, and thew switch fw is correct, it seems to be a SP problem and we dont know how to fix it!!???