Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Setting Password for VA7110 Manager GUI

SOLVED
Go to solution
Curtis Deese
Frequent Advisor

Setting Password for VA7110 Manager GUI

We are not prompted for a username or password when accessing our VA7110 Manager GUI. How is a password set for the utility and how do we get the password prompt back? We used to get the password prompt before a software upgrade. Any help would be appreciated!

Thank you!
Curtis
6 REPLIES
Sameer_Nirmal
Honored Contributor
Solution

Re: Setting Password for VA7110 Manager GUI

You need to enable "User Security". It is enabled by setting parameter "SECURITY_ENABLED=true" in file
/opt/sanmgr/commandview/server/config/PanConfigParams.txt

Start and stop SDM daemons using

# /opt/sanmgr/commandview/client/sbin/HA_Dial_Stop

# /opt/sanmgr/commandview/client/sbin/HA_Dial_Start

Once the user security is enabled,you would be prompted with login screen. Then try using your earlier username/password. If it doesn't work, then login with default username/password as Administrator/administrator and then add a new user.

Refer the CommandView SDM document at
http://h20000.www2.hp.com/bizsupport/TechSupport/CoreRedirect.jsp?redirectReason=DocIndexPDF&prodSeriesId=64112&targetPage=http%3A%2F%2Fh20000.www2.hp.com%2Fbc%2Fdocs%2Fsupport%2FSupportManual%2Fc00662561%2Fc00662561.pdf
Curtis Deese
Frequent Advisor

Re: Setting Password for VA7110 Manager GUI

I set SECURITY_ENABLED=true in file /opt/sanmgr/commandview/server/config/PanConfigParams.txt and stopped and started the SDM daemons. Now, when I try to access the SDM GUI I get the following error: "Login failed. You are not allowed to access this system." I still do not get a login prompt. Is there a configuration file where I need to add the IP address of the machine I am trying to access the SDM GUI from?

Any help would be appreciated. Thanks!

Curtis
Sameer_Nirmal
Honored Contributor

Re: Setting Password for VA7110 Manager GUI

The file name where you need to put the IP address of the system from where you are accessing the SDM GUI is

# /opt/sanmgr/hostagent/config/access.dat
Curtis Deese
Frequent Advisor

Re: Setting Password for VA7110 Manager GUI

Thank you for your quick response. I added the IP address of host I am trying to access the VA7110 Manager GUI from in the file, turned on the security, restarted the VA7110 Manager daemons, and now I get the following error:

Login failed. You are not allowed to access this system.

I am not prompted for a password. What other configuration settings do I need to change so that I get a login prompt and can access the GUI?

Thank you,

Curtis
V.Manoharan
Valued Contributor

Re: Setting Password for VA7110 Manager GUI

Hi
enter the Ip adderss in the following files
1. CommIPAddr.TXT
2. access.dat
3.run the following
./HA_Trigger stop;
./dial_trigger stop;
./HA_Trigger start
./dial_trigger start
4.armdiscover

Thanks and regards
V.Manoharan
Sameer_Nirmal
Honored Contributor

Re: Setting Password for VA7110 Manager GUI

Run these commands from the host to which the array is connected or the host who manages the array and see what you get

# armdsp -i
# armdsp -L

I assume that you have an entry for 127.0.0.1 in the access.dat file.

Check the file /etc/opt/sanmgr/hostagent/config/commIpAddr.txt file.
for correct IP address of the host. This IP should be reachable from the GUI client. If you change this file, restart the daemons. This is often a case during CV SDM installation and the host has multiple IP addresses ( multiple lan cards ). So this file may get no-desired IP address.

Do you see the file /opt/sanmgr/commandview/server/data/UserDBFile ? non-zero size maybe?

CommandView SDM has it's own web server . So you need to check if the web server is running and the default port 4096 is available for connection ( http client request).Check the file /opt/sanmgr/commandview/server/browserSDM/conf.xml for the port number configured. If you change this file, restart the daemons.