Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Array 5300 drives do not rebuild

Michael James Crawford
Occasional Visitor

Smart Array 5300 drives do not rebuild

We have 2x14 bay chassis ataches to a 5300 controller (fully populated). 2 drives have no lights at all and the array reports as requiring rebuild.

We have replaced the 2 drives in question with brand new drives, a rebuild starts, runs for a few minutes then stop and the lights go out on the drive. Please can you advise what the problem is?
4 REPLIES
kris rombauts
Honored Contributor

Re: Smart Array 5300 drives do not rebuild

Hi Michael,

can you pls specify some more detail like:

- how the raid config and logical drive
config is setup here over the 2 channels.
- which disks, if any, are hotspare disks.
- do you get an error, i.e. look at the
system.evt logfile if this is Windows.
- run the ADU utility and attach the
report.txt to this forum so people can
check.
ADU (Array Diagnostic Utility) can be
downloaded from hp.com.

- eventually post a print screen of the ACU

etc etc



One of the reasons a rebuild stops before it finishes is because another disk in the array has a bad spot on it's media and the data cannot be read i.e. This means that for raid1 and raid5 and worst case also in raid ADG you can have a situation where a rebuild cannot be completed.
This is because their part of the raid stripe missing and as such the stripe cannot be rebuild ever.
If this is the case, best thing to do is to
backup data, delete array and re-create a new one. Eventually also replace the disk that has the media issue and which causes the rebuild to fail. This is just a theory of what could be happening, again their is more detail needed to fully analyse this for you.



HTH

Kris


Michael James Crawford
Occasional Visitor

Re: Smart Array 5300 drives do not rebuild

Hi,

RAID config is all 28 drives in a ADG raid array.
1 logical drive
No hot spares
Event log shows lots of CPQISSE, DMIO, DISK and CPQISSM info, warning and error logs (primarily for BUS 1 ID 2 and BUS 4 ID 8)
ADU Report attached
kris rombauts
Honored Contributor

Re: Smart Array 5300 drives do not rebuild

Michael,

basde on the ADU report, this config is in a bad shape currently, it seems something happened about 6 days ago. As of then all 4 SCSI busses received regular resets. This could explain some errors you mentioned in the eventlog like timeouts etc. It would be interesting to see the system.evt log also to trace back as of when this started and with which disk first. If all mgmt agents are installed you should have a pretty good view on which disk or which problem occured first and focus on fixing that. Pls attach the system.evt here if you want.


Almost all disks need a disk F/W upgrade and the SA5304 controller itself runs very old firmware, i would advise you to get this updated.

Disk id=8 on bus 4 is bad:

SCSI Port 4, Drive ID 8 ... S.M.A.R.T. predictive failure errors have been
detected in the factory Monitor and Performance data. SOLUTION: Please
replace this drive when conditions permit.

RIS copies between drives do not match

Disk id=2 on bus 1 also has many errors but does not seem to be flagged as completely bad at this time.


Pls call HP support to get this fixed and make sure you have a backup of your data as data integrity might be at risk soon if not already.

HTH

Kris

kris rombauts
Honored Contributor

Re: Smart Array 5300 drives do not rebuild

Michael,

looking furtehr into the ADU details, it seems these disks have unrecoverable read errors:

- port 1 ID=2 Fl Rd Recv 464
- port 1 ID=3 Fl Rd Recv 154


This together with port 4 id=8 being bad is enough to cause a rebuild to fail since their is only one array here and one logical drive.

I am afraid you'll have to:

- backup data
- get the bad disks out
- update all disk f/w and controller f/w
- recreate array and restore backup.


HTH

Kris