Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Array 5312 not recovering

Jim Pfening
Occasional Visitor

Smart Array 5312 not recovering

We have an ML530 G2 with a Smart Array 5312 containing 3 72.8 GB disks. We are running Red Hat AS 2.1.

We had a drive fail, so we replaced it. The system was going through the automatic recovery, but two days later it wasn't finished and system performance was very slow. We rebooted and started the automatic recovery again.

It has been a few days and using ADU the system is now reporting that it is "ready for recovery."

I am attaching the last ADU report for reference.

I am not sure what to do next. Any help or suggestions will be appreciated.

Thank you.
5 REPLIES
Prabhulj
Valued Contributor

Re: Smart Array 5312 not recovering

Hi Jim,

Thanks for the ADU report,
From the ADU report, its reported that the Drive on SCSI Port1 Drive ID 0 has failed.

Replace this drive on SCSI Port1 ID 0
Model number: BD0726459C

Reason for Failure: There are too many read errors detected on this drive.

Sense Code recorded on this drive is 11 and 13
i.e 0x11 points to Read errors on the drive.
The Counters for HRD read on this drive is
Factory : 001577e1
Since Power: 0009d40a


Reference to Interpret SCSI Sense Code
http://docs.hp.com/en/A5159-96003/apas01.html?btnPrev=%AB%A0prev

Hope replacing this drive would resolve the issue.

Regards,
Prabhu


Jim Pfening
Occasional Visitor

Re: Smart Array 5312 not recovering

Thank you for the explanation on the sense codes.

Since I just replaced the drive at SCSI Port1 ID1, and the boot up utility shows that drive as a replacement. How am I able to tell if the drive has been recovered to enable me to replace the other failed drive at SCSI Port 1 ID0?

Without knowing that the recovery is complete, I am uncomfortable with pulling the other failing drive.

Thank you.
Jim Pfening
Occasional Visitor

Re: Smart Array 5312 not recovering

Also, the LEDs on the drives are as follows:

drive 0: activity: on, online: on, fault: off

drive 1: activity blinking, online: off, fault: off

drive 2: activity blinking, online: on, fault: off

Thanks for your help.
Prabhulj
Valued Contributor

Re: Smart Array 5312 not recovering

Hi Jim,

could you please upload an other ADU report from this server?

Regards,
Prabhu
Jim Pfening
Occasional Visitor

Re: Smart Array 5312 not recovering

Sorry for the delay. I was out of town last week. I was able to April 29th I wasable to take the system down to single user and kill off uneeded system processes for about 6 hours. I then started the rebuild and watched it over the week.

I was hoping this message would be good news because two hours ago ACU was reporting that the rebuild process was at 99.5% complete. And now it is reporting "ready for recovery." I let it rebuild for over a week and was feeling very lucky this afternoon.

The LEDs on the replacement drive are now off except for a slowly blinking activity light.

I have attached the latest ADU report for additional info. I am hoping for some good news. Like if I reboot the system and restart the rebuild it will take an hour to complete the rebuild. (Not another week of rebuilding ending with a failed rebuild.)

Thanks.
Jim.