Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

SmartArray 6i on DL380

Danny Petterson - DK
Trusted Contributor

SmartArray 6i on DL380

Hi Gurus!

This is very important to me. Ive had an old DL3xx-server, where I moved one of the systemdisks (Suse Linux Enterprise 8), to a DL380 G4, and booted the machine. It works fine...but....

After reboot, I put in an aditional disk, to rebuild the systemdisk (it was RAID 1 on the original server), but it will not rebuild, because the all the disks on the DL380 is on port 2, and the "missing" disk (from the configuration from the old server, stored on the systemdisk Ive booted on) is supposed to be on port 1.

Ive tried everything I could come up with to replace the "missing" disk with a new one on port 2, using both GUI and hpacucli, but nothing works. I cant add a spare to the array, because it is in "interim recovery mode".

Workaround anyone? Its very important to me.

Thanx in advance.
5 REPLIES
pasquino bocci_1
Trusted Contributor

Re: SmartArray 6i on DL380

Hi,

How do you see the new disk in ACU (which state)?
Pasquino
Danny Petterson - DK
Trusted Contributor

Re: SmartArray 6i on DL380

Hi, thanx for your response.

The new disk is just unassigned. But due to the "interim recovery mode" Im not able to assiang it as spare (or anything else for that matter)
pasquino bocci_1
Trusted Contributor

Re: SmartArray 6i on DL380

Hi,

usually, interim recovery mode means you have a ba drive. If you are runing V2.56, upgrade to the latest 2.68A since there is a bug.
What you can do is to remove all the disks from the controllers, erase the controller configuration and put back the disks again.
The infos are also stored on the disks and you shouldn't loose data. Better to upgrade all the FW before doing this (Bios, Array FW and DISK FW).
Pasquino
Danny Petterson - DK
Trusted Contributor

Re: SmartArray 6i on DL380

Yeah, but that dont fix the problem.

I have the disk from SCSI-port 1 on an "old" server, and on the new server, which only has a port 2 connected on the backplane, the server boots fine, but cant finde the "old" mirror-disk, which it expects to be on port 1 (there is no port 1 on the new server).

I want to assign a spare/rebuild the mirror on a new disk placed on port 2, even though the old mirror expects the target-disk to be on port 1 (which, of cause, is not possible due to the above described facts).

And yes "interim..." means it thinks there is a bad disk.
pasquino bocci_1
Trusted Contributor

Re: SmartArray 6i on DL380

Hi,
you should get an error during POST.
Have you tried to declare "bad" the disk which cannot be mirrored?