Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

SmartArray P212 forces server into perpetual reboot cycle.

BoomSchtick
Occasional Contributor

SmartArray P212 forces server into perpetual reboot cycle.

I have a P212 that I am trying to put into a Lenovo ThinkServer TS140.  At one point, I had VMWare running on this server with a Windows instance running off of an SSD and four 2TB drives in RAID 5 through the P212. 

It was working, but not well.  Transfering data to the big drive on the array was very slow.  It would pause the file copy in random places on large files and would pause for a maddening amount of time after each file no matter how big or small they are.  This was true whether copying from the network or an external hard drive.

 

I read a VMWare KB that said that the P212 and it's ilk were known to have this problem and a firmware update fixed it.  I busted out my Ubuntu flash drive and booted to it.  I updated the firmware of the P212 as root from the command line and now the server will NOT boot with the P212 installed.  The server will come on and briefly show a Lenovo splash screen and show the P212 initializing the array.  It shows the little spinning stars and flashes that there is one logical drive configured and the server reboots.  There is no way to get into the array management by pressing F8 and I can't get into the server BIOS by pressing F1 because the server does not accept any management keystrokes until AFTER the array card has initialized.  Thus since the server reboots after every initializing, I can't get into the bios.  I can't get it to boot to a USB or CD drive.  It will do nothing but continue to loop through the same frustrating cycle. 

All functions work fine when the P212 is out of the system.  I can boot to what I want when I want from any device I choose, but there is no love when the P212 is in the mix.

 

I have tried tweaking everying in the Lenovo BIOS that I can think of to no avail.  I have re-flashed the latest BIOS on the Lenovo just to make sure it was sound.

 

I know that the P212 works because I put it into an ML350 G5 and I was able to reflash it's firmware through Windows.  Also, I have three P212's and none of them will work in this Lenovo.

 

It's SOOOO frustrating!