Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble creating Command Device on XP 512

Trouble creating Command Device on XP 512

Hello there,

I'm trying to create a command device using a CSV. Unfortunately it fails to do so. Please take a look at attached file for error message.

I've tried several different things e.g.

- Use different lun on the port
- Use a lun on different port
- Create lun and assign as command device in one action

Is this problem occuring because there is too much happening on the port?
Is the only way around this to remove port from SAN Zone temporarily - Assign command device - replace port in zone?

Thanks,

Kind regards

Mohammed Usman Ali
Storage Systems Administrator
Life is what you make it!
6 REPLIES
harry d brown jr
Honored Contributor

Re: Trouble creating Command Device on XP 512


Without wasting a lot of your time, I'd call my local HP CE for help.

live free or die
harry
Live Free or Die
Insu Kim
Honored Contributor

Re: Trouble creating Command Device on XP 512

The error that you're getting indicates that the disk array is servicing I/Os to the port that are being modified.
Make sure that you stop all IOs on the port that you configure a commmand device.
This can be achieved by manually switching all IOs on target port using LVM to another alternate port.

To switch access to the device to the path named .

# pvchange -s
Refer to the man page for more information.

Hope this helps,
Never say "no" first.
Hamdy Al-Sebaey
Regular Advisor

Re: Trouble creating Command Device on XP 512

Mohammed,
I gree with Harry,just make a call by HP.
I'm working with xp256 & xp512,sometimes when I challenge a problem which I could'nt solve it,just not to waste my time I meld a call by HP.
Regards,
Hamdy
Thanks for sharing knowledge

Re: Trouble creating Command Device on XP 512


Thanks for the reply guys.

I thought it might be because activity was taking place on the port... So I removed the XP port from our SAN zone so that nothing could access the port. When going through the process of creating the command device I still got the same error message. Weird!

Stuck in the mud, I've taken the advice to log the inevitable call with HP. Let's see what happens. In the meantime if anyone knows what else I could try to do I would really appreciate it.

Thanks

Mohammed Usman Ali
Storage Systems Administrator
Life is what you make it!
Vincent Fleming
Honored Contributor

Re: Trouble creating Command Device on XP 512

It sounds like you are running into a common problem...

There are 2 modes of operation for CommandView - Online and Offline. If you pick Offline, then it will not allow any changes to the ports if it sees *any* type of activity on the port. This includes being attached to a switch.

Online mode should allow additions (not deletions) from the port while it's online.

So, you could either use Online mode, or remove the cable from the port at the XP - which will then allow modifications in Offline mode.

Good luck!
No matter where you go, there you are.

Re: Trouble creating Command Device on XP 512

Hi,

Sorry, I should have mentioned that I was using Remote Control to create the command device. Having tried everything it still failed miserably.

However, now this is weird... I went into CommandView, selected the lun I wanted as a cmd device and then selected the cmd device button. To my suprise it worked (and finished within a few seconds).

I went back into Remote Control / Lun Management and found that the command device had successfully been created.

I don't understand why it failed in RC and worked with CommandView. I was definitely in Offline mode (besides you cannot perform task in online mode). Oh well, I have command devices now so I'm happy.

Regards

Mohammed.
Life is what you make it!