Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

V5.1A - move boot disk to KZPCC

SOLVED
Go to solution
John Welsh_2
Regular Advisor

V5.1A - move boot disk to KZPCC

I have a DS20E running V5.1 PK6. The boot disk
is currently DKA0 and there are several RAID
data disks on the KZPCC. I did a vdump/vrestore
of "a" and "g" to a new mirror disk on the KZPCC. ( New mirror seen OK when booted from DKA0 ). Changed the root_domain and usr_domain
links in ./etc/fdmns to point to the mirror.
When I boot the mirror I get "msfs_mount: The mount device does not match the linked device.
Check linked device in /etc/fdmns/domain. Setting root device name to root_device RW "

I can mount /usr OK as usr_domain#usr but can't get root to mount. Tried a doconfig but no luck. Is there somewhere apart from the Hardware Database that the root device is remembered ?
Thanks in advance.
4 REPLIES
Vladimir Fabecic
Honored Contributor
Solution

Re: V5.1A - move boot disk to KZPCC

Hello
You must understand hwmgr stuff very well. You did something wrong while changing fdmns links.
First try this way:
1. Do not change fdmns links
2. Change /etc/fstab instead of fdmns links
For example: Cloned root domain is root1_domain (or whatever you named it), cloned usr domain is usr1_domain etc.
so put new root in fstab:
root1_domain#root advfs rw ...
3. Boot the system and rename domain if you want
In vino veritas, in VMS cluster
John Welsh_2
Regular Advisor

Re: V5.1A - move boot disk to KZPCC

Thanks Vladimir, I duplicated the problem and your solution on my DPW600 test box and your method worked fine.

I also came up with a second solution after thinking about it and using hwmgr and dsfmgr.
(See the Tru64 V5.x DOCS ).

Do the vdump | vrestore of root, usr (and var if var is a seperate file system ) from the current bootdisk to the new bootdisk.

Write a new bootblock to the new disk.

hwmgr -view dev and make a note of the current bootdisk id and the new disk id.

Physically remove the current bootdisk.

boot -fl s the new bootdisk
mountroot - it complains about links.
hwmgr -delete component -id
dsfmgr -m

Then reboot and all is restored.....

Thanks again Vladimir, I was in a loop thinking that I should try to resolve a problem with the KZPCC and your suggestion
got me thinking along other lines.
Best Regards,
John W.
======
John Welsh_2
Regular Advisor

Re: V5.1A - move boot disk to KZPCC

Ooops....typo in my above reply:

hwmgr -view dev and make a note of current bootdisk ID and NAME and new bootdisk ID and NAME.
.
.
.
dsfmgr -m

eg: dsfmgr -m dsk10 dsk0

JW.
==
John Welsh_2
Regular Advisor

Re: V5.1A - move boot disk to KZPCC

Vladimir's solution was correct plus I worked out another solution.