Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

VA7100 assorted woes

SOLVED
Go to solution
Carlos Sotelo Ibarra_1
Frequent Advisor

VA7100 assorted woes

I'm trying to configure a VA7100 with 10 36.4Gb drives two 1Mb controllers attached to a HP9000 server running HP-UX 11.11.
When trying to install a security table according to manual it gave me an "invalid parameter" error.
When trying to upgrade firmware (in order to solve previously noted problem) to ver. HP13, it gave me an "unable to complete" due to "current array state" ("ready", as far as I can see). Armdsp still shows it as using firmware rev. HP02, so I assume the firmware download was aborted at its inception and that no "halfway through" firmware is loaded.
Lately, when we added four disks to the original six pack it entered into a "balancing" mode, and it's been there for most of the evening (7 1/2 hours already) while giving an "advisory lock" to any configuration attempts (such as trying to enable hotspare, or trying to read the security table, in order to replace it with a new one).
Any ideas on solving at least one of these problems,... like by tomorrow morning?
A pint of Guiness is worth an ounce of prevention
10 REPLIES
Garett VanBeber
Occasional Visitor

Re: VA7100 assorted woes

Perform a "partial reset" via the VFP. Hopefully you have SDM version 1.01. Behavior is set to HP-UX? You need to break the advisory lock. I believe it is armmgr -b Check manual again. Try FW update to HP13 again. Sounds like it may also be performing a "disk scrub" This may be normal, dont worry too much there. Do you have a LUN 0 of 10 MB? Security can be tricky on these too. Dont bother with that until you get the fw updated. You should also be able to get a CE onsite to help you.

Good luck

Garett_VanBeber@hp.com
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 assorted woes

Garett:
Thank you for the prompt response... you must be working real late or real early, anyhow...
I seem to have SDM version 1.01, I do have the 10Mb LUN 0, though some of the error messages I get refer to not being able to access /dev/rdsk/c3t0d0, which is precisely LUN 0.
Behavior on both controller ports is set to HP-UX,as it was since the unit was first configured, but I just did a double check on it through VFP and CommandView, just to be sure.
As you suggest, I'm holding up on the security issue for now.
I've checked the printed manual over and over... are there any updates on it available? We've downloaded some from the website, but we haven't had the chance to print them yet... don't know if they are very different.
Thanks again for the prompt answer!
A pint of Guiness is worth an ounce of prevention
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 assorted woes

Performing the partial reset did the trick of allowing me to access the VA again. I had to break an advisory lock in order to get it to respond to commands again though. When I did the balancing process did get underway (it seems beforehand it was in a kind of loop, since there seemed to be a lot of IO activity and little or no disk activity) and finished in about two hours.
Still can not load the security table or upgrade the firmware. Any ideas?
By the way. Garett should have had at least an 8. Sorry that I can't get back and upgrade the points...
A pint of Guiness is worth an ounce of prevention
Marc Dijkstra
Trusted Contributor

Re: VA7100 assorted woes

I take it that the SecureManager feature is enabled? Check with armfeature.

If so does you sec. table look suchly:
DEFAULT null 0 WC
NODEWWN 1 W
NODEWWN 2 W etc...

then the command to upload sec. table?
armsecure -c -w -f -P

The -c clears the table and disables the security, so armsecure -e -P will re-enable it.

Having a look at the fw problem, in the meantime could you attach the output of your security table?

MND

"A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila"
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 assorted woes

Thank you for your help... enclosed please find the files you requested ".out"'s are output files, mostly from armdsp commands. ".in"'s are the files I'd like to get into the VA... the Firmware file I downloaded from the corresponding site in www.hp.com. I changed the name from A6188AHP13.FRM to a6188a.hp13 in order to have CommandView recognize the file. Does this have any impact on the download issue?
A pint of Guiness is worth an ounce of prevention
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 assorted woes

Sorry, I forgot to add, Security is disabled, in order to allow me to work with the VA while the security table does not work...
The "out" files as far as the sectable is concerned are "default" values assigned by the VA when the LUN's were created...
The "in" file is supposedly according to the manual formats...
Funny to remark. We were able to install a sectable before, and it worked fine... it was after we changed the LUN's that we were not able to load the sectable anymore.
Thanks again you all for your help.
A pint of Guiness is worth an ounce of prevention
Marc Dijkstra
Trusted Contributor

Re: VA7100 assorted woes

Hi there... we are obviously on VERY different timelines.

Firstly, your inusetable...
DEFAULT null 0 WC
nodewwn 0x50060b000009d101 1 WC
nodewwn 0x50060b000009d101 2 WC

The nodewwn should be caps, NODEWWN. The second error is the WWN itself, I think you can safely get rid of the 0x in front of it. To get the CORRECT hostport WWN use the armtopology command.

Still looking at the firmware.

MND
"A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila"
Marc Dijkstra
Trusted Contributor

Re: VA7100 assorted woes

Carlos

Looking at the manual, I think that the fw file must also be caps.

Check your firmware with the following:
armdownload -I C

then use the armdownload command again to get it to the controller, remembering that you only do it to one, the other will be automatically updated:
armdownload -C -O /A6188AHP13.frm

Change the .FRM to .frm

MND
"A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila"
Marc Dijkstra
Trusted Contributor
Solution

Re: VA7100 assorted woes

Ooops.... boo-boo...

the armdownload -C -O is for offline... online just do the armdownload -C

apologies!

MND
"A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila"
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 assorted woes

Thanks to all parties involved. I solved all of my problems with the VA7100. Sorry that I let this issue linger too long. I should have closed the thread earlier and assigned the points to Mark, but hey... you know how this is...
Thanks again to all posters for their helpful responses.
Carlos Sotelo
A pint of Guiness is worth an ounce of prevention