Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

VA7100 can't get close to nominal capacity

SOLVED
Go to solution
Carlos Sotelo Ibarra_1
Frequent Advisor

VA7100 can't get close to nominal capacity

We are setting up a VA7100 configured with 6 36GB disks. One as autoswap, that should leave 180GB available... but we are only able to allocate 63+GB!!! Is there a way of forcing the VA7100 into RAID 5dp mode in order to get to the rest of the space?
Also, how do we see how much space is actually available or allocated for each LUN
A pint of Guiness is worth an ounce of prevention
5 REPLIES
Enes Dizdarevic
Honored Contributor
Solution

Re: VA7100 can't get close to nominal capacity

Since you have capacity of 4 disks used for redundancy I suppose you have set autoraid mode with hot spare.
There is no way to force raid5dp on VA. You can only select autoraid or raid 1/0. You can disable hot spare. In that case capacity od 3 disks will be used for redundancy and you will have usable capacity of 3x36.
Your problem is that you have to few disks for autoraid configuration which gives very bad rate between usable and total capacity. If you had for instance 12 disks the rate would be 66% (with hot spare) or 75% (without hot spare).
Disk usage (allocated capacity, total capacity, redudancy,..) can be seen using command view. Select lun management, etc.
Vincent Fleming
Honored Contributor

Re: VA7100 can't get close to nominal capacity

Enes is correct that you can't force all-raid5dp right now. I thougth I'd mention that it is scheduled to be available mid 2002. (July or so)
No matter where you go, there you are.
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 can't get close to nominal capacity

I think my question was wronlgy stated at the beginning. I understand the VA7100 more thoroughly now, and see that the problem was not so much on forcing RAID 5DP as on changing the VA from RAID 1 to AutoRAID modes. Unfortunately there are no options in the CommandView UI to either query the VA on the mode or to set this mode.

This is done by accesing the Virtual Front Panel by connecting a terminal to the RS-232 port on the back of the controllers. At the prompt, we gave the "vfpmgr -B autoraid" command that sets the mode to AutoRAID, if, as it was our case, the VA7100 came factory configured to RAID 1.

There is still the question as to why hotspare would reserve the equivalent of two disks in order to work. I had to disable the feature altogether in order to get the desired working space. Any ideas here?
A pint of Guiness is worth an ounce of prevention
Enes Dizdarevic
Honored Contributor

Re: VA7100 can't get close to nominal capacity

Using CommandView user interface (windows UI or menu interface) you can not accomplish all possible configuration tasks. You have to use command line user interface (typing commands in command prompt or shell) to set active hot spare or raid mode: In CommandView 1.02 command for seting active hot spare is:
armmgr -h value, where value can be None, Automatic, LargestDisk, LargestTwoDisk.
Default value is Automatic (it usualy means LargestTwoDisk). Change it to LargestDisk.
Using armmgr -C you could set raid mode to raid1+0 or autoraid.
This two tasks can be accomplished from virtual front panel too. You already have found command for changing raid mode. I can not check it now but I think that command for changing active hot spare behavior using virtual front panel has the same parameters as in command line interface (vfpmgr instead of armmgr). So instead of disabling active hot spare change it to LargestDisk using either one of two possible methods.
Carlos Sotelo Ibarra_1
Frequent Advisor

Re: VA7100 can't get close to nominal capacity

Danke!

I'm trying to install the new version of CommandView. I 've got problems, however, with the firmware download.
I guess that's a different issue, altogether, but thanks for the help on the capacity issue.
A pint of Guiness is worth an ounce of prevention