Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

XP1024 MPIO AIX with VIO Server

Rex Pommier
Frequent Advisor

XP1024 MPIO AIX with VIO Server

Hi.

I have an IBM p570 that I'm trying to attach to an XP1024 for boot and data volumes. The kicker here is that I want to use VIO Server to serve up the disk (VIOS code 2.1 which is AIX 6.1 under the covers). What I want to do is set up 2 VIO servers to access the same LDEV on the XP1024 so I can then serve the LDEV to the client LPAR as a dual attached LUN, so that I can service either of the VIO servers without taking down the client LPARs. Has anybody done this? I am using an IBM redbook that says it can be done (at least with IBM disk) but when I attempt to run the mkvdev command on the second VIO server I get error

Method error (/usr/lib/methods/cft_vt_scdisk) : 0514-047 Cannot access a device

If I tear down the virtual link on VIO1 I can then successfully run the mkvdev command on VIO2, so it is apparently something not liked trying to hook both VIO servers to the same LDEV.

Is what I'm trying to do even possible? If somebody has done it, can you tell me what I'm missing?
3 REPLIES
IBaltay
Honored Contributor

Re: XP1024 MPIO AIX with VIO Server

Hi,
this could be an inspiration:
http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=lpg30064&jumpid=reg_R1002_USEN

even for the older then XP1024 XPs..

the compatibility should be checked also here:
http://h20272.www2.hp.com/
the pain is one part of the reality
IBaltay
Honored Contributor

Re: XP1024 MPIO AIX with VIO Server

Rex Pommier
Frequent Advisor

Re: XP1024 MPIO AIX with VIO Server

Thanks for the pointers, IBaltay. Unfortunately they weren't what I needed. I was already past that point, and the first set of links talked about directly attaching the LPARs to the XP arrays instead of using the VIO servers as intermediaries.

It turns out the piece I was missing was to set the reserve_policy in AIX on the hdisks to no_reserve. The HP documentation that I was using seemed to indicate that I needed to have them set to single_path but that is what was stopping me.

Rex