Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

XP256 and RaidManager

Bernd Reize
Trusted Contributor

XP256 and RaidManager

Hello there,

we have two XP256's with CA for mirroring each other.
On the Host side we use RaidManager to handle PVOL / SVOL switching.
Last week, we updateted both XP's to microcode 48.06 and, to follow HP's recommendations, updated RaidManager to v01.05.03.
The problem now is: when trying to start a horcm instance, it fails. in the error log is the message:
[....]
09:24:20-be25b-08266- horcread():this device is not a command device.:/dev/rhdisk9
09:24:20-c16bb-08266- [WARNING] This device(/dev/rhdisk9) is not ready for receiving a command.
09:24:20-c56c2-08266- No device is ready for receiving a command in 1 line from HORC_CMD.
09:24:20-c857d-08266- ERROR:horcm_cfg_create
09:24:24-ed8bb-07592- horcmgr:Failed to connect to HORCM.

This message appears both on HP-UX11.00 hosts, and on AIX 4.3.3 Hosts.
Anyone knows a solution? Probably a bug in the RaidManager software?
3 REPLIES
Vincent Fleming
Honored Contributor

Re: XP256 and RaidManager

Gruess Sie;

Do you still have a command device? Perhaps the firmware update undid the CMD dev designation. Look at the Command View or LUN Config Mgr screens to find out. The error messages are consistent with a missing CMD device.

Tschau!
No matter where you go, there you are.
Bernd Reize
Trusted Contributor

Re: XP256 and RaidManager

Hello Vincent,

that was the first guess from our xp software consultant, too.
Badly, it doesn't work. We even installed a new CVS Volume (36MB) and declared it as a CMD Dev. Doesn't make any difference from Host side.
By the way, for testing we installed an old RaidManager (v01.03.02) on the HP-UX Hosts. What surprise! This version worked. i.E. it was able to start an instance of RaidManger. Badly the horctakeover command only produces a Core-Dump, so it is unuseable.

Thanks for your help,
Bernd
Hans van der Meulen
Occasional Visitor

Re: XP256 and RaidManager

Hello,

On our XP1024 Firmware version 21-04-32 I also tried to active raid manager 1.09.04. After starting the horcm instance I recieve exactly the same error.

Cheers,

Hans