Disk Enclosures
Showing results for 
Search instead for 
Did you mean: 

hangs with p800 and msa60 after updating hp rhel4 driver

Occasional Advisor

hangs with p800 and msa60 after updating hp rhel4 driver

Last week I updated my RHEL 4.5 x86_64, p800 & msa60 system to this http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=329290&prodSeriesId=1157686&swItem=MTX-fa46191f5ce84304b0a84a2d57&prodNameId=1157691&swEnvOID=2026&swLang=8&taskId=135&mode=3


At the same time, I changed the strip size to 128K from 64K.

The array worked fine for around 4 days that took to complete the change of strip operation.

Then the next day it froze up: anything trying to access the msa60 went into the D state, including ACU and the cli. Trying to umount the filesystem (gpfs) resulted in kernel panic.

During the reboot a message frpm p800 showed up: "a conroller failure event occured
prior to this powerup" there were some hex codes too but I did not write them down.

After two days, the same happened again, I did a remote power cycle but I was unable to see if the p800 spitted the same error again.

With the previous driver I had not such problems.

Am I doing something wrong or the new driver is to blame? If it happens again, I will try with the old one.