Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

msa1500flash rpm install problem with Linux SUSE 10

Richard Freiss
Occasional Visitor

msa1500flash rpm install problem with Linux SUSE 10

Has anyone attempted to load the rpm that is provided for firmware update of the MSA1000
using LINUX SUSE 10 on a DL380?


The rpm is not compatible with SUSE 10 library files.




5 REPLIES
Ivan Ferreira
Honored Contributor

Re: msa1500flash rpm install problem with Linux SUSE 10

>>> The rpm is not compatible with SUSE 10 library files.

I'm not sure about that, first of all, you should ensure that the libraries required are on disk, that is, the rpm package that includes that libraries are installed. You must have these libraries installed:

libart_lgpl.so.2()(64bit) is needed by msa1500flash-5.20-7.x86_64
libgnome.so.32()(64bit) is needed by msa1500flash-5.20-7.x86_64
libgnomesupport.so.0()(64bit) is needed by msa1500flash-5.20-7.x86_64
libgnomeui.so.32()(64bit) is needed by msa1500flash-5.20-7.x86_64
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Richard Freiss
Occasional Visitor

Re: msa1500flash rpm install problem with Linux SUSE 10

I should have made this clear.

SUSE 10 has newer versions of the required libraries.

I don't believe that I should need to install olded versions.

SUSE 10

These are two of the new files:
gnome/lib/libgnome-2.so.0
gnome/lib/libgnomeui.so.32


The download indicated that the rpm supprted SUSE 10. I've checked the packages in question. The supplied rpm has an older version.

The files in question are on my SUSE 9 Server installation.
Ivan Ferreira
Honored Contributor

Re: msa1500flash rpm install problem with Linux SUSE 10

Sometimes, "compat" packages are distributed that includes old libraries. Another option is to install the rpm without checkin the dependencies, and crate symbolic links to the newer libraries, with the name of the expected file.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Richard Freiss
Occasional Visitor

Re: msa1500flash rpm install problem with Linux SUSE 10

I was able to install with --nodeps but the
shared libraries were still worng. Tried the link this did not help.

Compat was looked into as well.

My next try will be to get the needed libraries from SUSE 9.

Richard Freiss
Occasional Visitor

Re: msa1500flash rpm install problem with Linux SUSE 10

Problem resolved.

I was using an early release of SUSE10 SP1.

The proper libraries are in SUSE 10 without SP1 installed.