Disk Enclosures
cancel
Showing results for 
Search instead for 
Did you mean: 

vdisk h/w path is not detected

 
S.S.
Super Advisor

vdisk h/w path is not detected

Dear All,

I have create 7 vdisks at EVA and also presented the LUNS from the host and detected by ioscan command whereas for my 8th vdisk i have created with 500gb at EVA and presented the LUNS also but it is not detecting by ioscan command. I executed this command frequently and waited for 20min even also that h/w is not detected.

May i know what will be reason?

Thanks!
21 REPLIES 21
Jupinder Bedi
Respected Contributor

Re: vdisk h/w path is not detected

you can check at the storage end , there must be a problem on the storage end or san switch.
All things excellent are as difficult as they are rare
Prasanth Thomas
Valued Contributor

Re: vdisk h/w path is not detected

Hi,

please let me know update for the below queries.
please run the ioscan command

#ls -ltr /dev/dsk
#uname -a
please confirm from sorage end that the this lun is properly created and assigned.

Regards,
Prasanth Thomas.
Prasanth Thomas
Valued Contributor

Re: vdisk h/w path is not detected

what was the size of other vdisks?.
S.S.
Super Advisor

Re: vdisk h/w path is not detected

Hi Prasanth,

The other vdisks are of size 200gb, 150gb, 60gb like that. I have created these vdisks under FATA disk group.
For all these vdisks i have detected the LUNS whereas only for 500gb disk.

Justnow, i tried to delete this 500gb and created with 200gb and presented the LUNS to the host at EVA level and i checked for these LUNS at O/S level by ioscan even though also the LUNS are not detected.
Prasanth Thomas
Valued Contributor

Re: vdisk h/w path is not detected

Hi,
whats the version of OS ?.
is it a production server?.

Regards,
PT
S.S.
Super Advisor

Re: vdisk h/w path is not detected

Hi,

Now, i presented the LUNS to another host [test server] and tried to execute the ioscan command and it has been detected.
bobsam
Advisor

Re: vdisk h/w path is not detected


Hi Dear,

Please check at your storage end, that the LUN presented properly to the host or not,

Your remaining 7 LUNS getting means hope there is no problem with your SAN zoning.

In sever before ioscan just execute

#insf -e
#insf -eC disk

then check ioscan, Hope the disk will detect.

thanks,
Prasanth Thomas
Valued Contributor

Re: vdisk h/w path is not detected

just want to update you that sometimes you have wait for 5-10 minutes.

After presenting the LUN please run the ioscan command and the verify whether the new lun is showing or not. If not please run the insf -C disk command ,in the o/p you can see the new device file.

Regards,
Prasanth Thomas
Prasanth Thomas
Valued Contributor

Re: vdisk h/w path is not detected

#uname -a