EVA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

HELP! - P2000 G3 Round Robin problems on Windows Server 2008

 
Highlighted
Pedro Eleuterio
Occasional Visitor

HELP! - P2000 G3 Round Robin problems on Windows Server 2008

Hello

 

I have the exact same problem described on this unanswered post: http://h30499.www3.hp.com/t5/Disk-Disk-Arrays-Legacy/P2000-G3-No-Roundrobin-Policy-selectable-in-Windows-Server-2008/td-p/2371759

 

The problem is:

 

We have a P2000 G3 iSCSI in a 2 Controller configuration with all 8 Ports connected (via 2 separate LAN-Segments on 2 HP Switches; 2 per Controller and LAN). I can see the 2 configured LUNs on Server 2008 device manager, and disk management, and even the Multipath Device.

 

However, in spite of 8 iSCSI ports/portals and two P2000 controllers, I can only see one Target on iSCSI Initiator (MSA2000 G1 had two, one for each controller). And after two double logon sessions on separate LAN NICs, I can't configure round robin as Load-Balancing Policy, neither via iSCSI-Control Panel nor via Commandline (in Windows Server 2008, NOT R2).

 

"Round Robin with subset" remains the default, which is not the same thing.

 

The iSCSI initation control panel states "parameter incorrect" when trying to chance Load balance policy from FailOver only to Round Robin, probably due to the absence of "Round Robin" on Multipath Device, in device manager.

 

Two years ago I configured a MSA2000i G1 on a Server 2003, and in spite of some complexity, the manual was very helpful, and has been working very well on the last 2 years.

But I have already lost an unmeasurable amount of time with this problem no P2000, with no success. Until now I tried:

 

- Updated both controllers to the latest firmware (T230 I think, from July 2011)

- I followed all the instructions on the latest P2000 G3 iSCSI DSM manual about Server 2008 MPIO installation and configuration

- Installed the HP DSM package, most recent version (4.01.01). Works ok, but no round robin

- After adding "HP      P2", I also added ""MSFT2005iSCSIBusType_0x9"" on MPIO devices, with no effect

- restarted servers N times (but not the P2000)

 

Server 2008 mpclaim options are more limited than on 2008 R2 version, but it think it should work anyway. I attached 3 useful screenshots.

 

I might try Round Robin with an old Server 2003 later, but I need this on my Server 2008 servers. Does anyone have the same problem? Am I missing something? This shouldn't be so diffcult. Is there any solution for this problem?

 

 

Thank you in advance,

 

Pedro

 

2 REPLIES 2
Highlighted
Travis Langhals
Occasional Visitor

Re: HELP! - P2000 G3 Round Robin problems on Windows Server 2008

Highlighted
Igor-admin
Occasional Visitor

Re: HELP! - P2000 G3 Round Robin problems on Windows Server 2008

I had the same problem and managed to solve it just a few moments ago :) and want to share it with all of you.

I made the same actions as described in this forum

http://social.technet.microsoft.com/Forums/da-DK/winserverfiles/thread/1efd460a-7031-45c9-b922-2da2418f5156

 + additional steps in solution.

 

Solution:

- In Device Manager choose properties of "HP P2000 G3 iSCSI Multi-Path Disk Device"

- In MPIO tab select MPIO policy: Least Blocks

- Press Details button in DSM Name (Microsoft DSM) field

- Enable "Path Verify Enabled" checkmark.

 

After enabling the Path Verify i was able to distribute the load on two iSCSI ports ( it can be seen in Task manager on Networking tab).