EVA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

I can't view LUNs in HP EVA3000

 
SOLVED
Go to solution
Highlighted
Occasional Advisor

I can't view LUNs in HP EVA3000

Hello,

I have installed vmware esx 3.5 U2 in a HP DL 585. This server has a atached 1 hba dual port emulex LP11002 connected to SAN HP EVA3000 VCS3028.


I added a host in the Command View EVA as says VMware Infrastructure 3, HP StorageWorks best practices.

*In Command View EVA, set the host OS name parameter to Custom.
*For an active/passive EVA3000/5000 array, use host mode type 000000002200282E.
And I added the hba ports to this host.
And virtual disks.

When I rescan the hbas in the ESX hosts I can´t see any LUN. If I restart de ESX host the result is the same.
I have made this one two days ago. Today morning when I rescan the hbas again I was be able to see the LUN, but when I restarted tke ESX host I lost the LUN again.


Any idea!!.

Thanks

Pablo






19 REPLIES 19
Highlighted
Honored Contributor
Solution

Re: I can't view LUNs in HP EVA3000

Hi,
maybe this doc could help you:
http://h71019.www7.hp.com/ActiveAnswers/downloads/VMware3_StorageWorks_BestPractice.pdf
the pain is one part of the reality
Highlighted
Occasional Advisor

Re: I can't view LUNs in HP EVA3000

Thanks IBaltay,

I have yet configured the hosts, as says VMware Infrastructure 3, HP StorageWorks best practices.

*In Command View EVA, set the host OS name parameter to Custom.
*For an active/passive EVA3000/5000 array, use host mode type 000000002200282E.

If I follow this manual the result is the same. I can´t see any LUN.

Regards
pablo


Highlighted
Honored Contributor

Re: I can't view LUNs in HP EVA3000

and could you check
a) the persistent binding setting pls?http://h71028.www7.hp.com/ERC/downloads/4AA1-1119ENW.pdf
b) the fabric zoning

if everything is ok pls?
the pain is one part of the reality
Highlighted
Honored Contributor

Re: I can't view LUNs in HP EVA3000


I looked in the SPOCK database and there is no reference for ESX 3.5, only 2.5.x and 3.0.x.

VCS 3.028 is supported on 3.0.x, but not on 2.5.x.

Minimum VCS of 3.110 for ESX 2.5.x

Now... 3.5.x... not sure. Might need to call support to get that information, but i would think it would be at least whatever 3.0.x supports.... but I could be wrong.


What version of Command View are you running?

Also, what about your SAN Switch firmware and hba firmware/driver?

You can look up the driver for the hba easily while in the SAN Switch gui, just look at the name server in the gui.


Steven
Steven Clementi
HP Master ASE, Storage, Servers, and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5, vSphere 6.x)
RHCE
NPP3 (Nutanix Platform Professional)
Highlighted
Honored Contributor

Re: I can't view LUNs in HP EVA3000

Having no reference could also mean that it is not supported on a 3000.


Steven
Steven Clementi
HP Master ASE, Storage, Servers, and Clustering
MCSE (NT 4.0, W2K, W2K3)
VCP (ESX2, Vi3, vSphere4, vSphere5, vSphere 6.x)
RHCE
NPP3 (Nutanix Platform Professional)
Highlighted
Occasional Advisor

Re: I can't view LUNs in HP EVA3000

Hello,


a) the persistent binding setting pls? http://h71028.www7.hp.com/ERC/downloads/4AA1-1119ENW.pdf

I can´t find this script in /usr/sbin in esx 3.5 u2.
[root@rianxeira sbin]# ls *.pl
setup-hostd-dsuser.pl vmkuptime.pl vmres.pl vmsnap.pl
[root@rianxeira sbin]# find / -name pbind.pl
[root@rianxeira sbin]# pwd
/usr/sbin
[root@rianxeira sbin]# ls *.pl
setup-hostd-dsuser.pl vmkuptime.pl vmres.pl vmsnap.pl
[root@rianxeira sbin]#


b) the fabric zoning

I have unique zone and esx can see everything.

Thanks
Highlighted
Occasional Advisor

Re: I can't view LUNs in HP EVA3000

hbas firmware:BS2. 70A5
Command View EVA 5
Switches firmaware: I don´t know. I don´t manage de switches. I tryed to connect switches to the lan to manage it. I think the zonning is OK because if I install a Windows machine in the same host I can se the LUNs correctly.

Regards
Highlighted
Honored Contributor

Re: I can't view LUNs in HP EVA3000

Hi Pablo,

When you "added the hba ports to this host" did you select the WWNs from the drop down list, or did you type them in manually ??

If the latter, then I'll guess that something is probably wrong with your SAN switch zoning.

Hope this helps,

Regards,

Rob
Highlighted
Honored Contributor

Re: I can't view LUNs in HP EVA3000

Hmmm... According to VMware, the EVA3000 is not supported on ESX 3.5.

http://www.vmware.com/pdf/vi35_san_guide.pdf

(page 15)

If I were a betting man, I'd take a guess that if you were to upgrade the EVA to an Active/Active version of VCS (4.x) then things might work, but you'd still appear to be in unsupported territory.

Cheers,

Rob