EVA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

c7000 BladeSystems switch connecting HBA qlogic or emulex

 
SOLVED
Go to solution
Garrri4
Occasional Visitor

c7000 BladeSystems switch connecting HBA qlogic or emulex

Hi all.
Earlier in my site was only eva4400 & server with HBA cards: emulex and qlogic. They connected directly.
Today's sitution I have c7000 enclosure with cisco 9000 switch. I easily connect eva to switch by chousing fabric option instead direct. But I don't know how to connect hba to switch, cisco device manager says that this link is offline. May be I must change hba mode to fabric? Where is it?
5 REPLIES 5
Terri Harris
Honored Contributor

Re: c7000 BladeSystems switch connecting HBA qlogic or emulex

I am assuming this is the c-class interconnect Cisco MDS switch,which is a MDS 9124e or the new 8GB switch. Either way, it slides into the back of a c7000 enclosure.

The c-class Cisco MDS interconnect switch has 16 internal ports to allow up to 16 blade servers to log in internally. You cannot physically see these internal ports.
A blade server will automatically log into the internal port (port number is same as blade bay number) when the following conditions exist (this is assuming no BFS - Boot from SAN):

1. The blade server in bay x has a FC HBA installed in the right mezz slot.
2. The blade server is powered on.
3. The blade server has a OS installed and a supported FC HBA driver.
4. The Cisco MDS port is not shutdown.

If the MDS switches are in interconnect bays 3 & 4, then a FC HBA mezz card (Emulex or Qlogic) must be installed in mezz slot 1 of that blade server. Mezz slot 1 is the mezz connector closest to the system board.

Let me know if you have any questions.
Garrri4
Occasional Visitor

Re: c7000 BladeSystems switch connecting HBA qlogic or emulex

Hi, Terry.
My explanation wasn't clear to you. My bad.
Actually I have old 2U server, which works on site when I haven't c7000 ecnlosure. So, no interconnect, problem with external connection, device manager says link is offline, led on backwards of switch burn green, leds on server hba burns orange.
Víctor Cespón
Honored Contributor
Solution

Re: c7000 BladeSystems switch connecting HBA qlogic or emulex

You need to specify what hardware you have.

First the switch on the C7000 enclosure, MDS 9124e or Cisco MDS 8Gb?

http://h18000.www1.hp.com/products/quickspecs/12653_div/12653_div.pdf

http://h18000.www1.hp.com/products/quickspecs/13821_na/13821_na.pdf

Then the HBAs on the server

Is the switch port configured for auto-sensing the speed?

The new 8 Gbps switch does not support 1 Gbps HBAs, so check that too.

Also, that you're using a supported SFP: AE379A for 4 Gbps and AJ906A for 8 Gbps.
Garrri4
Occasional Visitor

Re: c7000 BladeSystems switch connecting HBA qlogic or emulex

Thanks problem solved by restarting server.
Garrri4
Occasional Visitor

Re: c7000 BladeSystems switch connecting HBA qlogic or emulex

Solved.