cancel
Showing results for 
Search instead for 
Did you mean: 

fca2214 - va7410

 
Aldert van der Laan_1
Occasional Contributor

fca2214 - va7410

We have two DL380 g3 servers running RH Linux ES 2.1 with FCA2214DC cards in them. I am planning to connect these servers to Brocade switches and a VA7410. I have done this for NT servers and HP-UX servers without a problem.
The Brocade sees the WWN in the Name server and I made sure I defined the nodes in Commandview.

The cards simply will not see the Luns. I have configured the cards in their bios to Fabric (point to point) and allowed WC to the LUNs needed. I am within the limits of the Secure Manager license and so.... I am puzzeled.

We have now two calls open and no responses from HP support other than being on hold for hours and hours on end.

Anyone here hooked these things together?
3 REPLIES
Highlighted
Eugeny Brychkov
Honored Contributor

Re: fca2214 - va7410

Make sure:
1. you set up host behavior table and set Linux hosts' HBAs to Linux mode there;
2. check switchshow output at the brocades to make sure all ports are F-ports;
3. check lpfc.conf.c file, which version of driver you have loaded for FC HBAs.
Check all these and return here
Eugeny
Aldert van der Laan_1
Occasional Contributor

Re: fca2214 - va7410

Eugene here is some of the info:

Output from switchshow:

port 12: id N2 Online F-Port 21:01:00:e0:8b:2b:64:4c
port 13: id N2 Online F-Port 21:01:00:e0:8b:2b:cb:4d


Linux boot information:


qla2x00_set_info starts at address = f8a76060
qla2x00: Found VID=1077 DID=2312 SSVID=e11 SSDID=101
scsi(0): Found a QLA2312 @ bus 3, device 0x1, irq 15, iobase 0x00004000
scsi(0): Allocated 4096 SRB(s).
scsi(0): Configure NVRAM parameters...
scsi(0): 64 Bit PCI Addressing Enabled.
scsi(0): Scatter/Gather entries= 32
qla2x00_nvram_config link_down_timeout=0x8
scsi(0): Verifying loaded RISC code...
scsi(0): Verifying chip...
scsi(0): Waiting for LIP to complete...
qla2x00_isr(0): asynchronous MBA_LINK_MODE_UP.
scsi(0): LOOP UP detected.
qla2x00_isr(): asynchronous MBA_LOOP_UP.
scsi(0): Port database changed.
scsi0 qla2x00_isr: asynchronous MBA_PORT_UPDATE.
qla2x00_get_retry_cnt(0): done. mb3=200 ratov=10.
scsi(0): Topology - (F_Port), Host Loop address 0xffff
scsi0: Enter qla2x00_configure_fabric: hba=f6ca8084
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=1
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=2
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=3
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=4
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=5
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=6
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=7
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=8
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=9
qla2x00_gnn_ft(0): GNN_FT retryingretry_count=10
qla2x00_find_all_fabric_devs GNN_FT Failed-Try issuing GAN
qla2x00_find_all_fabric_devs(0): use_gan=1 dpc_flags=0x0
scsi0 Found (0) ports
scsi0: qla2x00_configure_fabric: exit
qla2x00_configure_fcports(0): LOOP READY
DEBUG: detect hba 0 at address = f6ca8084 - adding to hba list
scsi(0) qla2x00_isr MBA_PORT_UPDATE ignored
qla2x00: Found VID=1077 DID=2312 SSVID=e11 SSDID=101
scsi(1): Found a QLA2312 @ bus 3, device 0x1, irq 11, iobase 0x00004400
scsi(1): Allocated 4096 SRB(s).
scsi(1): Configure NVRAM parameters...
scsi(1): 64 Bit PCI Addressing Enabled.
scsi(1): Scatter/Gather entries= 32
qla2x00_nvram_config link_down_timeout=0x8
scsi(1): Verifying loaded RISC code...
scsi(1): Verifying chip...
scsi(1): Waiting for LIP to complete...
qla2x00_isr(1): asynchronous MBA_LINK_MODE_UP.
scsi(1): LOOP UP detected.
qla2x00_isr(): asynchronous MBA_LOOP_UP.
scsi(1): Port database changed.
scsi1 qla2x00_isr: asynchronous MBA_PORT_UPDATE.
qla2x00_get_retry_cnt(1): done. mb3=200 ratov=10.
scsi(1): Topology - (F_Port), Host Loop address 0xffff
scsi1: Enter qla2x00_configure_fabric: hba=f6660084
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=1
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=2
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=3
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=4
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=5
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=6
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=7
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=8
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=9
qla2x00_gnn_ft(1): GNN_FT retryingretry_count=10
qla2x00_find_all_fabric_devs GNN_FT Failed-Try issuing GAN
qla2x00_find_all_fabric_devs(1): use_gan=1 dpc_flags=0x0
scsi1 Found (0) ports
scsi1: qla2x00_configure_fabric: exit
qla2x00_configure_fcports(1): LOOP READY
DEBUG: detect hba 1 at address = f6660084 - adding to hba list
scsi(1) qla2x00_isr MBA_PORT_UPDATE ignored
scsi0 : QLogic QLA2312 PCI to Fibre Channel Host Adapter: bus 3 device 1 irq 15
Firmware version: 3.02.16, Driver version 6.06.50

scsi1 : QLogic QLA2312 PCI to Fibre Channel Host Adapter: bus 3 device 1 irq 11
Firmware version: 3.02.16, Driver version 6.06.50
Aldert van der Laan_1
Occasional Contributor

Re: fca2214 - va7410

Important:

I just went and dug a little deeper into the VA7410 with Commandview. Although the cards have been set for point to point (read = Fabric Mode) they are still being seen by the VA7410 as if they are in LOOP DEVICE mode.

Is there something wrong with the firmware of these cards?

They are running the latest HP Approved firmware 1.34