General
cancel
Showing results for 
Search instead for 
Did you mean: 

2.2.14 kernel on P4 machines

Chakravarthi
Trusted Contributor

2.2.14 kernel on P4 machines

Does anyone installed 2.2.14-6.1.1 ( redhat 6.2) on pentium 4 machines,

help required

thanks
chakri
5 REPLIES
Stuart Browne
Honored Contributor

Re: 2.2.14 kernel on P4 machines

Any particular reason you are trying to use such an archaic distribution on such new hardware?

Unless the kernel was specifically compiled for a given CPU class, it should work. Even if it was compiled for i[356]86 specific, it should still work.

Whilst the P4 added a swag load of new instructions, it is fully backwards compatable.

What errors are you getting at what point?

It sounds like you've upgraded an old system, so it's probably more of an 'initrd' driver problem than a CPU incompatability.
One long-haired git at your service...
Chakravarthi
Trusted Contributor

Re: 2.2.14 kernel on P4 machines

installation is not happening, the basic problem is it cant detect the architecture
Stuart Browne
Honored Contributor

Re: 2.2.14 kernel on P4 machines

Ok, so you're trying to *INSTALL* RH6.2 on a P4 machine.

Why?

I fail to think of even *ONE* good reason too.
One long-haired git at your service...
Stuart Browne
Honored Contributor

Re: 2.2.14 kernel on P4 machines

Ok, so you're trying to *INSTALL* RH6.2 on a P4 machine.

Why?

I fail to think of even *ONE* good reason to.
One long-haired git at your service...
dirk dierickx
Honored Contributor

Re: 2.2.14 kernel on P4 machines

The installation failing on your P4 machine of rh6.2 is probably because it can't detect your hardware properly, the chipsets used by the p4 were not yet available at the time of the 2.2.x kernels.
however this is just guessing, maybe you can post your error messages here so we can take a closer look.
although i must agree that you're better of with rh7.2/7.3 since it contains several advantages missing from previous releases.