General
cancel
Showing results for 
Search instead for 
Did you mean: 

2 PSP components not installing (yes, SUSE Ent 9 again)

SOLVED
Go to solution
Eric Meiring
Frequent Advisor

2 PSP components not installing (yes, SUSE Ent 9 again)

It looks like I'm going for the shotgun approach today, with several topics. Anyway...

HP DL360 G3 w/SUSE Linux Ent 9. I updated to the 2.6.5-7.252 kernel from Online Update, and have that source installed as well.

I got the latest PSP from HP's site and went to install it (install740.sh). It runs ok and installed all but 2 components, and I can't figure out why.

The 2 components are:
1) HP NC10xx/65xx/77xx/150x/320x/325x Gigabit Ethernet NIC
2) HP Tested and Approved Linux 802.1q VLAN Driver

Both fail with a similar message:
"A command, "/usr/bin/make -s -e -C ${KERNELSRC} oldconfig >/dev/null" necessary to complete the installation failed with error code 2: "no such file or directory". Installation of this component FAILED."

Any idea what's up, or where to begin? I simply looked for /dev/null, and that folder indeed is not there, but I have no idea why or what to do.

Thanks!
5 REPLIES
Jun Yu
Frequent Advisor

Re: 2 PSP components not installing (yes, SUSE Ent 9 again)

Hello Eric again & again :-),

The PSP contains drivers, management agents, utilities. When apply the pack, it will check your current system and verify the installed package version before really update it. It will check it's kernel dependency as well.

1) failed, your 252 kernel may has the newer driver than PSP740 gave you.

2) failed , this vlan driver only support SUSE LINUX Enterprise Server 9 for x86 Service Pack 2(kernel dependency)


JOe Yu
just for fun
Eric Meiring
Frequent Advisor

Re: 2 PSP components not installing (yes, SUSE Ent 9 again)

Hmm - ok. So it seems that they failed to install not because of a problem, but more because they were not needed?

I guess I'd expect it to not even attempt the install in that case. Perhaps the "failure" is just misleading then, as you indicate, and all is well.

Thanks again (and again!) for the reply. :)
Michael Garner_1
Honored Contributor
Solution

Re: 2 PSP components not installing (yes, SUSE Ent 9 again)

Eric,
The issue you are seeing is caused by older drivers in the PSP for SLES9. The 7.40 PSP was only tested up through kernel -191 and will attempt to install on later kernels if the driver in the PSP will rebuild on errata kernels. The two components you show are two components that will attempt to rebuild on the new kernel.

In the short-term, you can download the latest versions of these drivers directly from the hp.com website and install them based on the instructions in their associated readme files.

The links to the latest versions of these drivers are:
NC10xx - http://h18023.www1.hp.com/support/files/server/us/download/23968.html
VLAN - http://h18023.www1.hp.com/support/files/server/us/download/24186.html

Regards,
Michael Garner
HP Linux PSP Developer
Eric Meiring
Frequent Advisor

Re: 2 PSP components not installing (yes, SUSE Ent 9 again)

Thanks guys. I see exactly what the deal is now - thanks for the responses!

-Eric
Eric Meiring
Frequent Advisor

Re: 2 PSP components not installing (yes, SUSE Ent 9 again)

Closing thread since I have received the information I was looking for.

Thanks again folks!