General
cancel
Showing results for 
Search instead for 
Did you mean: 

ACU For Linux ES 3.0 for Itanium Platform is not working

Muhammad Kashif
Occasional Contributor

ACU For Linux ES 3.0 for Itanium Platform is not working

Problem Type: Array Configuration Utility(ACU) installed without any errors but unable to use for array configuration.

Environment: Itanium rx4640 is connected with MSA1000 storage using
Qlogic 2300 HBA. Red Hat Linux enterprise server 3.0 (64 bit) is
installed with update 4 on the server.

Problem Detail: We installed HP Array Configuration Utility (ACU) for 64
bit Linux from the site
http://h18007.www1.hp.com/support/files/storage/us/download/19795.html
it is installed properly but when we run System management page from
browser (http://127.0.0.1:2381), can't see ACU option there. MSA is
accessable & we can see all the harddrives i.e. 14 drives installed on
MSA through System management page on browser.

When we run ACU following result shown on screen:
[root@itanium2 root]# cpqacuxe
Array Configuration Utility version 6.41.2.0
The Array Configuration Utility (ACU) allows you to configure and manage your storage through a web browser.
Server Mode Usage:
cpqacuxe [option]
Options: (use one only)
-h, --help Show this page.
-v Show version information.

Scripting Mode Usage:
cpqacuxe [option] [filename]
Options: (use one only)
-c Capture configuration to a script file. Default file is acucapt.ini.
-i Input configuration from a script file. Default file is acuinput.ini.
See ACU documentation for script file syntax.


Note:
Make sure that you have gone through the following checklist:
1. Change the administrator password to something other than
the default.
2. Only run ACU on servers that are on a local intranet
or a secure network.
3. Secure the management port (port 2301 or 2381)
on your network.


3 REPLIES
Steven E. Protter
Exalted Contributor

Re: ACU For Linux ES 3.0 for Itanium Platform is not working

Shalom,

The command line for acu requires options.

Which are you using.

Hopefully you are using something.

The utility itself may be bad and you may need a patch or secondary update.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Muhammad Kashif
Occasional Contributor

Re: ACU For Linux ES 3.0 for Itanium Platform is not working

Hi SEP,
As i said i run cpqacuxe command for running the services of ACUXE(If i am not wrong). I had not used any options.I used HP Management Page to access ACU .I think after installation of cpqacuxe you also have link for it in HP Management Page.Need help on this.
Ross Minkov
Esteemed Contributor

Re: ACU For Linux ES 3.0 for Itanium Platform is not working


1. Run the ACU server

First check if there is an ACE server running already:

# ps auxw | grep cpqacuxe

If you see output like this:

root 26604 0.0 0.1 34872 7536 ttyp2 S 13:41 0:00 /opt/compaq/cpqacuxe/bld/.acuxebin -R
root 26605 0.0 0.1 34872 7536 ttyp2 S 13:41 0:00 /opt/compaq/cpqacuxe/bld/.acuxebin -R
root 27312 0.2 0.1 34872 7536 ttyp2 S 13:41 0:03 /opt/compaq/cpqacuxe/bld/.acuxebin -R

then the ACU server has been already started.

If you need to start the ACU server make sure you are root and run:

# /usr/sbin/cpqacuxe -R

More options can be found by running "cpqacuxe --help".


2. Run the ACU client

For a list of supported browsers see the /opt/compaq/cpqacuxe/README.TXT file on a ProLiant server that has the ACU installed.

Use a supported browser and go to:

http://SERVERNAME:2301

Login to System Management Homepage and click the ACU button under Storage.


HTH,
Ross