Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Auto RAID errors...

Brian Atkins
Advisor

Auto RAID errors...

This morning, we performed a full shutdown on our T500 system, including the autoraid, to take inventory of all the equipment. This included removing and reinstalling all the components in the autoraid cabinet (disks, fans, and power supplies).

Following the inventory, the autoraid was powered back on prior to powering on the machine. It took longer than normal to run the diagnostics and finally hung on "controller 90 y". We assumed the we had not reseated the controller properly, so we did so. Still no luck. We tried swapping x controller for y controller, also no luck. We even tried powering it on with one controller pulled out, but that didn't work, either.

Each time, it reaches "controller 90 y" and hangs. We are not able to interact with it from the front panel.

As a last resort, we swapped the controllers for 2 known good controllers, but failed once more.

We powered on the system to try and perform diagnostics, but continue to receive messages for all of the volumes in the array:

vgchange: Warning: couldn't query physical volume "/dev/dsk/cXtXdX":
The specified path does not correspond to physical volume attached to
this volume group.

We have since tried powering it on starting with only one disk, powering it off, trying it again with two... etc.

Physically, the raid appears to be fine, no dust, debris, bent pins, etc.

Any clues?
2 REPLIES
Kevin Wright
Honored Contributor

Re: Auto RAID errors...

replace the controller with a new one, then run
vgchange -a y /dev/vgXX for all the volume groups that you are getting those errors for. I had a similar problem and this fixed it.
Steve Lewis
Honored Contributor

Re: Auto RAID errors...

I could be a firmware issue. Ensure that you have the latest. We had a couple of hangs ourselves and upgrading to >=HP56 fixed it.
I know the position of the disks is supposed to be irrelevent but I wouldn't rely on such things - are you sure you put them back in the same place?