cancel
Showing results for 
Search instead for 
Did you mean: 

Automount Issue !

SOLVED
Go to solution
titu
Regular Advisor

Automount Issue !

When I remove the nfs automount from SAM it again mount back after some interval.

what is the correct procedure to stop automount.

Thanks in advance.
5 REPLIES
Pete Randall
Outstanding Contributor
Solution

Re: Automount Issue !

I would set "AUTOMOUNT=0" in /etc/rc.config.d/nfsconf and reboot. You might be able to stop nfs services via "/sbin/init.d/nfs* stop" but I've never had much luck that way so I just reboot.


Pete

Pete
titu
Regular Advisor

Re: Automount Issue !

But if i remove the automout using sam is it temperory umount it ?
Pete Randall
Outstanding Contributor

Re: Automount Issue !

You don't mention which version of HP-UX you are running so I'm going to answer from my 11.11 experience.

I think you're referring to "Sam > Networking and Communications > Networked File Systems > Mounted Remote File Systems > Actions > Disable Automounter". I can't say as I've ever tried it, but Sam's help screens say that it will set AUTOMOUNT=0, unmount all automounted remote files/directories, and kill the automount daemon. As long as the unmounting is completely successful (unlikely, in my opinion), this should work.

In my experience, it is impossible to get all the remote mounts unmounted. Some user, somewhere will be cd'd into an automounted directory and the umount will not succeed. I would proceed as I described earlier. Edit /etc/rc.config.d/nfsconf to set AUTOMOUNT=0, then reboot.


Pete

Pete
titu
Regular Advisor

Re: Automount Issue !

Hello Pete ,

This is 11.11 system.
I am able to umount using the filesystem option in sam and disable automounter , i am not able to remove the nfs filesytem using option remove in the same window.
TTr
Honored Contributor

Re: Automount Issue !

You only need to stop the NFS client service with "/sbin/init.d/nfs.client stop" (and restart it with the start option). If you can't stop the NFS client because you have other NFS mounts from remote servers, you can stop the automount service by doing the following

This is from the /sbin/init.d/nfs.client script in the "stop" case.

/usr/sbin/unmountall -F autoFS

Find the process ID of the automountd daemon using the "ps" command and kill it.

kill