Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Boot problems with Fedora 13/14 on a EliteBook 8540w

noldi
Valued Contributor

Boot problems with Fedora 13/14 on a EliteBook 8540w

Hi,

I have a strange problem with a recent EliteBook 8540w with an Nvidia NVIDIA Quadro FX 880M graphics option.

When running with the Linux Nouveau driver for Nvidia cards, the system locks up during the boot almost every time. I then have to reset the system and try a few times until it boots.

When it eventually boots, I have no issue whatsoever with the NB until I shut it down / reboot.

I've a bugzilla running at https://bugzilla.redhat.com/show_bug.cgi?id=630765 which is not making any progress, so I wonder if anybody else has this problem at all?

If somebody could boot a recent Fedora Live image and report no problems, this would indicate to me that I have some kind of HW problem . .

Thanks much & Regards,

Arnold
4 REPLIES
Steven E. Protter
Exalted Contributor

Re: Boot problems with Fedora 13/14 on a EliteBook 8540w

Shalom Arnold,

The Elite book was not designed for Linux in the first place.

It does the best it can, but is part of the HP notebook strategy that relegates low end systems to Windows only.

That being said, you should be able to get Linux work, if you are flexible about your distribution.

Try centos, or ubuntu live CD first and see how it goes.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
noldi
Valued Contributor

Re: Boot problems with Fedora 13/14 on a EliteBook 8540w

Hi SEP,

I wouldn't quite call an EliteBook 8540w a Low End System seeing all these Compaq and Pavilion models out there I must say . . ;-)

I know that HP Notebooks are built with Windows in mind but they do mention SuSE Linux Enterprise Desktop 11 as beeing "certified" in the QuickSpecs for example.

Changing the distribution is not (yet) an option for me as I'm in the other camp.

Best Regards,

Arnold


Harri Hokkanen
Occasional Visitor

Re: Boot problems with Fedora 13/14 on a EliteBook 8540w

I have been running 8540w since May 2010. First install was Fedora 12 64-bit with proprietary Nvidia driver. All functioned perfectly. Upgrade to Fedora 13 64-bit was full of problems. As being portable client tested also Ubuntu 10.04 64-bit. Most of the things worked out of the box giving time to concentrate on actual work and not tweaking the OS.

Then upgrade to Ubuntu 10.10 64-bit worked also OK.

We run full business environment on Linux using Centos 5.5 with EPEL on servers, virtualisation with ESXi on SSD, Centos 5.5 and Fedora 13 on workstations depending on work. Scientific 6 is on Lab on testing for future production environment.

Our focus turned on Ubuntu 64 and our HP laptops after 8540w started to have problems. M/B was changed four (4) times until the system became "stable" again. Main problem was first dead system and then CPU temperature between 70-102 C.

The system was also unstable on Windows 7 64bit.

After all repairs I did clean install of Ubuntu 10.10 64bit. Everything seemed fine.

On virtualisation servers we found out Ubuntu 10.10 systems (even 32bin clients) running high system loads while CentOS and Fedora clients were running on zero load when idle.

We noticed that Ubuntu 10.10 systems on four or more cores (32 and 64 bit) run on high system loads even on idle. For a comparison Fedora 13 64-bit and Scientific 6 64-bit on four and eight cores run on near zero load on idle.

Similar symptoms on 8540w and 8440p laptops. Nvidia is causing Fedora 13 64bit to hang and Ubuntu 10.10 to be graphically sticky time to time.

I agree Windows relation is too tight and restrictive for a professional use. On businesses working on web environment tools are not Windows based.

As 8540w is labelled professional MobileWorkstation the user experience is more like with consumer products. On business environment (at least in Europe) we are free to choose the tools best for purpose.

So we are in mercy of market analysts, sales force and engineers. Professional products should be have also focus on niche groups who are pushing the technology forward and not just following trends.



noldi
Valued Contributor

Re: Boot problems with Fedora 13/14 on a EliteBook 8540w

Hi Harri,

thanks for your thoughts.

Yesterday I started to have boot problems from my internal SSD disk but I'm up again.

To me, it looks like I'm having hardware problems with my QC 8540w so I might turn it in for repair after taking a full backup.

Best Regards,

Arnold