General
cancel
Showing results for 
Search instead for 
Did you mean: 

CDE unable to launch due to ups_mond error

mizie
Occasional Visitor

CDE unable to launch due to ups_mond error

Hi,

I'm having a problem which our server RX2620 unable to launch the CDE login. Once reboot, it stuck in command prompt with error '/usr/lbin/ups_mond: UPS /dev/tty1p0 read failed: File exists; Uninterruptable Power Supply has not been connected correctly; loss of power would not be detectible'

I've check the physical connection between ups and server. Everything is connecting.

Here are some output catched.

# ioscan -fnC tty
Class I H/W Path Driver S/W State H/W Type Description
==================================================================
tty 0 0/6/1/0 asio0 CLAIMED INTERFACE PCI SimpleComm (103c1290)
/dev/diag/mux0 /dev/mux0 /dev/tty0p0
tty 1 0/6/1/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/diag/mux1 /dev/mux1 /dev/tty1p0 /dev/tty1p2 /dev/tty1p4
tty 2 250/1 asio0 CLAIMED INTERFACE Built-in RS232C
/dev/diag/mux2 /dev/mux2 /dev/tty2p0
tty 3 250/2 asio0 CLAIMED INTERFACE Built-in RS232C

# more /etc/ups_conf
shutdown_delay_mins:5
shutdown_timeout_mins:5
upstty:/dev/tty1p0



Please advice.

Thanks.
-mizie-
6 REPLIES
Torsten.
Acclaimed Contributor

Re: CDE unable to launch due to ups_mond error

I don't think ups_mond and CDE are related.

However, I'm almost sure that /dev/tty1p0 is the console device.

Does this work before?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: CDE unable to launch due to ups_mond error

IMHO /dev/tty0p0 is the UPS port.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
mizie
Occasional Visitor

Re: CDE unable to launch due to ups_mond error

Yes..it's working properly before.

The problem just happen today, after we recabling our server room. We just unplug and replug back all the physical cable connection.

Once try to boot the server, our server unable to launch the CDE. It stucks at command prompt with error '/usr/lbin/ups_mond: UPS /dev/tty1p0 read failed: File exists; Uninterruptable Power Supply has not been connected correctly; loss of power would not be detectible'.
Torsten.
Acclaimed Contributor

Re: CDE unable to launch due to ups_mond error

Make sure you use the connector labeled "UPS" on the server.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
mizie
Occasional Visitor

Re: CDE unable to launch due to ups_mond error

Hi,

The connection is using 'UPS' connector.


# ioscan -fnC tty
Class I H/W Path Driver S/W State H/W Type Description
==================================================================
tty 0 0/6/1/0 asio0 CLAIMED INTERFACE PCI SimpleComm (103c1290)
/dev/diag/mux0 /dev/mux0 /dev/tty0p0
tty 1 0/6/1/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/diag/mux1 /dev/mux1 /dev/tty1p0 /dev/tty1p2 /dev/tty1p4
tty 2 250/1 asio0 CLAIMED INTERFACE Built-in RS232C
/dev/diag/mux2 /dev/mux2 /dev/tty2p0
tty 3 250/2 asio0 CLAIMED INTERFACE Built-in RS232C


From the output above, which tty is pointed to UPS. Need your advice.
Torsten.
Acclaimed Contributor

Re: CDE unable to launch due to ups_mond error

I told you.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!