cancel
Showing results for 
Search instead for 
Did you mean: 

CRON email no longer forwarding

SOLVED
Go to solution
Randy Kennedy
Occasional Visitor

CRON email no longer forwarding

HP/UX - crons under both root and a user. They all used to come to an exchange account via the .forward file for both users. However, after applying several updates, the emails no longer come. If I remote to the server and run elm, I can see all of the emails and I can send an email from either account to the exchange account manually, but we want to get the cron/at emails.

Any ideas what could have changed during the updates?

TIA,
Randy
6 REPLIES
Jeff_Traigle
Honored Contributor

Re: CRON email no longer forwarding

What updates were applied? What version of the OS is installed? I'd hazard a guess that a sendmail patch was included since sendmail is what would handle forwarding via the .forward file.
--
Jeff Traigle
Randy Kennedy
Occasional Visitor

Re: CRON email no longer forwarding

uname -a
HP-UX hp9ux3 B.11.11 U 9000/800 112414650 unlimited-user license

Embarassingly, 754 patches were applied to get our server current. Yes, there was sendmail updates.

I have been playing around with command line email sending and have discovered the following as well that may be some indication of the problem.

As root, I ran:
la a*b*c | mailx -s test user@host.com and it sent the email to user@host.com just fine.

When I run it as the other user with cronjobs, I get
ksh: host.com: not found

I also notice that when trying to enter an fully qualified address in elm to test, as soon as I type the @, everything already entered is deleted.

That would seem to indicate another error with the regular user, but I don't get the cron emails from root either and I don't have the "@" problem with the root account.
Dennis Handly
Acclaimed Contributor

Re: CRON email no longer forwarding

Have you looked at the mail logs,/var/adm/syslog/mail.log? What are the permissions of the .forward files?
Randy Kennedy
Occasional Visitor

Re: CRON email no longer forwarding

.fowards are 777

noon cron left this is log:
Dec 29 12:00:01 hp9ux3 sendmail[21076]: MAA21074: forward /usr/informix/.forward.hp9ux3+: World writable directory
Dec 29 12:00:01 hp9ux3 sendmail[21076]: MAA21074: forward /usr/informix/.forward+: World writable directory
Dec 29 12:00:01 hp9ux3 sendmail[21076]: MAA21074: forward /usr/informix/.forward.hp9ux3: World writable directory
Dec 29 12:00:01 hp9ux3 sendmail[21076]: MAA21074: forward /usr/informix/.forward: World writable directory
Dec 29 12:00:01 hp9ux3 sendmail[21076]: MAA21074: to=informix, ctladdr=root (0/3), delay=00:00:00, xdelay=00:00:00, mailer=local, st
at=Sent

sucessfully sending a test using the ls piped to mailx left this is the log.
Dec 29 12:48:11 hp9ux3 sendmail[21303]: MAA21301: to=user@host.com, ctladdr=root (0/3), delay=00:00:00, xdelay=00:00:00,
mailer=relay, relay=smtp.host.com [172.19.62.4], stat=Sent (2.6.0 <201012291948.MAA21301@hp9ux3.host.com> Queue
d mail for delivery)
Dennis Handly
Acclaimed Contributor
Solution

Re: CRON email no longer forwarding

>When I run it as the other user with cronjobs, I get
ksh: host.com: not found
>I also notice that when trying to enter an fully qualified address in elm to test, as soon as I type the @, everything already entered is deleted.

I don't think this is your crontab problem. The problem with "@" is that you need to change the stty(1) settings so that "@" isn't the kill char. Also you need to fix erase, "#".

You need to fix your .profile.
Dennis Handly
Acclaimed Contributor

Re: CRON email no longer forwarding

>.fowards are 777

This isn't allowed, a security breach.
Change to a=r. You may have to change it to allow read to just the user: u=r

> MAA21074: forward /usr/informix/.forward.hp9ux3+: World writable directory

You need to remove "o+w" from /usr/informix.

>successfully sending a test using the ls piped to mailx left this is the log.

This doesn't use .forward. (I assume user@host.com is a different machine.)