General
cancel
Showing results for 
Search instead for 
Did you mean: 

Can not load data to the Database ....

Bokoko
Advisor

Can not load data to the Database ....

Unfortunately, I can not upload data in the database. It seems to be a conflit with the Pre-compiler between two version of Oracle "7.3.4" & "8.0.6".

SQL-02127: Precompiler/SQLLIB version mismatch
SQL ERR -2127 AT P304 OF PAYMR1
SQL-02127: Precompiler/SQLLIB version mismatch

As I know, there is two separate directories for both version.....

I've checked all envionment variables and it is fine.... I download the database and it is also fine....
7 REPLIES
Paula J Frazer-Campbell
Honored Contributor

Re: Can not load data to the Database ....

Hi

Are you trying to get 7.3.4 into 8.0.6 or the other way around?

Paula
If you can spell SysAdmin then you is one - anon
T G Manikandan
Honored Contributor

Re: Can not load data to the Database ....

sqllib errors are because they are reffering to old libaries.

check the environmental variables as which oracle home they are referring.
Probably the old version is referred for oraclehome/lib

Bokoko
Advisor

Re: Can not load data to the Database ....

No I have two different Environments :

1. One working with 7.3.4

2. another one working with 8.0.6.

The Both Environments are set up properly and I can startup or shutdown separately as Oracle user switching to each of one separately....

What is happening ???? I'm running some external jobstreams using indexed files existing and loading them to the Oracle Database.... During this execution, I've found the firs error related to SQL-02127... (I'm running the PAY MERGE operation....

That's all.

Waiting for your assistance,

Engo.
Paula J Frazer-Campbell
Honored Contributor

Re: Can not load data to the Database ....

Does this happed with both versions ?

Paula
If you can spell SysAdmin then you is one - anon
Paula J Frazer-Campbell
Honored Contributor

Re: Can not load data to the Database ....

Sorry for the typo.


Is this load error happening on both versions?

Paula
If you can spell SysAdmin then you is one - anon
Bokoko
Advisor

Re: Can not load data to the Database ....

I did not test the 8.0.6. version yet... Actually, the data to be loaded is in 7.3.4..... I'd like to reinstall Oracle 8.0.6 and create the new instance for one Environment in 8.0.6 et see what wil happen...
Yogeeraj_1
Honored Contributor

Re: Can not load data to the Database ....

hi,

This happens when Your program is linked to an older version of SQLLIB, which is incompatible with this release of the Oracle Precompilers. Please relink your programs with 8.0.6 SQLLIB

Make sure you have installed 8.0.6 Client and you are under 8.0.6 HOME.
1. Check ORACLE_HOME and LD_LIBRARY_PATH = ($ORACLE_HOME/lib: .....)environment
variables they should be pointing to your 8.0.6 HOME .
2. Rename the existing object files / executables of the application. For example sample1.o to sample1.o.bak
3. Relink the application .
For example
make -f demo_proc.mk build OBJS=sample1.o EXE=sample1
4. Run the program from the 8.0.6 environment only

If you still face the problem please let us know your compile steps / output

hope this helps!

Best Regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)