General
cancel
Showing results for 
Search instead for 
Did you mean: 

Can not start or stop Oracle 8.1.7.3 DB.

SOLVED
Go to solution
Gino Castoldi_2
Honored Contributor

Can not start or stop Oracle 8.1.7.3 DB.

Hi,

HP-UX 11.0 Oracle 8.1.7.3 VPO 6.15 MC/sg 11.09

There were numerous sqlplus calls/processes being made in VPO which slowed the system down
so I decided to stop VPO and Oracle.

However on the primary node Oracle will not start up now, it lists these errors:

08/25/03 12:02:56 ERROR ovoareqsdr (Request Sender)(6932) [dcesec.c:925]: Can't

bind to DCE security service: No currently establish
ed network identity for which context exists (dce / sec). (OpC20-2645)
Database: ORA-00020: maximum number of processes (50) exceeded
(OpC50-15)
Could not connect to database ov_net.
Please look if the database processes are running. (OpC50-2)
Connect to database failed. (OpC40-410)

I can start up the "listener" manually but when I run SVRMGRL> startup
it gets these errors:
ORA 01081 "cannot start already-running ORACLE - shut it down first"

If I try to startup Oracle says it needs to be
running. Note: Our database is not in archive mode.

Any ideas as to how to fix this problem?

10 points to any good answer.
Thank you
Gino




5 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: Can not start or stop Oracle 8.1.7.3 DB.

Oracle has clearly not shut down clearly.


First try as oracle app user..

sqlplus internal
shutdown abort

startup

shutdown

Its important to do a start stop after an abort.

This may still fail.

If the application exe's are in a fileystem by themselves, you may want to shut open processes.

My oracle exe's have their own fs.

/oracle

fuser -cu /oracle

fuser -cuk /oracle blows away all open processes.

You may need to to the same thing on the filesystems that contain the oracle data.

This is last ditch.


You should be able to start oracle at this point.

If not check ipcs command and blow away the shared memory segments with ipcrm command.

If that doesn't help, see other suggestions and consider restarting the system.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Helen French
Honored Contributor

Re: Can not start or stop Oracle 8.1.7.3 DB.

This is from rp7410 technical white paper:

ORA-00020: Maximum number of processes (600) exceeded. This error may occur when workload testing is invoked. Make sure to increase the parameter of ???processes??? in ???init.tmp??? at setup time or in ???run_init.pops??? at run time. The original script set the value of 200 for version 8.1.5. It is recommended to set the value to 300 at setup time and 400 at runtime for Oracle version 8.1.6 and 8.1.7.

http://www1.itrc.hp.com/service/cki/cache/200000061824906.pdf
Life is a promise, fulfill it!
Brian Crabtree
Honored Contributor

Re: Can not start or stop Oracle 8.1.7.3 DB.

This is a common occurance. Oracle binaries automaticlly attempt to login to the database when you start them (ie: svrmgrl with 'connect internal'). While this says that you are connected, you attempt to do something (select * from x), and it says that the database is unavailable, because it cannot open a process with the database.

Just about the only way to resolve this is to increase the "processes" parameter in the init.ora under $ORACLE_HOME/dbs, and then login as internal to the database, and issue a "shutdown abort". This will force the database to kill any current running processes (including the database). A startup will run the database through a crash recovery, and your application should be able to login after that.

Let me know if you have any questions.

Thanks,

Brian
Indira Aramandla
Honored Contributor

Re: Can not start or stop Oracle 8.1.7.3 DB.

Hi,

Please try the following:-

1. Edit the database init.ora file
2. Locate and increase the processes parameter to a higher value.
3. Save the init.ora file
4. Stop and restart the database
try shutdown immediate before you try shutdown abort.
5. Re-connect to the database instance

The normal procedure to set the values for process is

SESSIONS
Default value: Derived: 1.1 * PROCESSES + 5

TRANSACTIONS
Default value: Derived (1.1 * SESSIONS)

And remember always to check kernel parameters for process limit (maxuproc/maxusers).

I hope this helps.
Never give up, Keep Trying

Re: Can not start or stop Oracle 8.1.7.3 DB.

I'd do the following :

1. sqlplus internal ->shutdown abort
2. ps -eaf|grep oracle ->kill all oracle processes
3. ipcs|grep oracle ->check for semaphores/memory segments still allocated to oracle
4. ipcrm -> remove any semaphores/memory segments assigned to oracle
5. try to restart your database