General
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't boot Ubuntu 8.10 on a DL185 after installation

Kimmo Gläborg
Occasional Visitor

Can't boot Ubuntu 8.10 on a DL185 after installation

When finishing the installation of Ubuntu 8.10 server (both 32 and 64bit) everything seems fine in the install and partition of the disks (and cpqarray). But for some reason the boot process after installation get's stuck after PXE with just a black screen with a white cursor blinking up in the left corner.. Anyone seen this?
4 REPLIES
Kodjo Agbenu
Honored Contributor

Re: Can't boot Ubuntu 8.10 on a DL185 after installation

Hi,

Never used DL185, so my answer is for general case.
Looks like the boot loader is not found by the BIOS.
=> Check the boot device order in the bios setup
=> Make sure you have the latest bios

Another test : left the Ubuntu CD inserted, then make the selection in the menu to boot from harddisk. If the boot is successful, force the GRUB configuration to be written on the disk (grub-install ).

Good lcuk
Learn and explain...
Kimmo Gläborg
Occasional Visitor

Re: Can't boot Ubuntu 8.10 on a DL185 after installation

Tried all of that, but the installation wont boot. I have the latest BIOS. When calling HP they told me that the DL185 G5 works with a maximum of 8 SATA drives, not 12. Tried to do a new array with only 8 disks as well, but no luck. It's still not working. I tried to install Ubuntu 8.04 LTS server version but when formatting it get stuck at 33%.

I've also tried this on 2 separate DL 185's to confirm that the issues are not something related to a hardware error.

Steven E. Protter
Exalted Contributor

Re: Can't boot Ubuntu 8.10 on a DL185 after installation

Shalom,

Ubuntu really was not intended as a server release. I'm not surprised this was not tested.

Check any raid configuration and make sure Linux is booting off anything but raid 5, it does not like raid 5.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Kimmo Gläborg
Occasional Visitor

Re: Can't boot Ubuntu 8.10 on a DL185 after installation

Marhaba Steven!

I doubt it's related to Ubuntu being a server operating system or not. (We can probably start another thread about that :). A fact is that 30%, -a majority of the Linux community is using Ubuntu as we speak. Don't know why HP still is sticking to RPM hell world.

I actually got 8.04LTS to work and booting well out of the box on hardware raid-1, but not raid-5. This is more than managed to do on CentOS and Suse out of the box with exactely the same config..