cancel
Showing results for 
Search instead for 
Did you mean: 

Can't get pop-3 running.

Can't get pop-3 running.

What I've tried so far:
RedHat 7.1 running as a server was hacked; root password was changed.
I reformated the hard drive and re-installed. Now pop-3 isn't working.
Somehow I missed the pop3 module in the install.The popper daemon
doesn't seem to start. Since everything else is working I'm trying to avoid
another reformat and reinstall.

pop3 entries are in the services file as shown below.
I made no changes to the services file.

/etc]# cat services | grep 110

pop3 110/tcp pop-3 # POP version 3
pop3 110/udp pop-3
kpop 1109/tcp # Pop with Kerberos


I noticed there was no tcp entry for port 110
in the /etc/sysconfig/ipchains file so I added one:

/etc]# cat sysconfig/ipchains | grep 110

-A input -s 0/0 -d 0/0 110 -p tcp -y -j ACCEPT


There was no pop3 file in /etc/xinetd.d so I added one:

/etc]# cat xinetd.d/pop3
# default: on

service pop-3
{
protocol = tcp
user = root
socket_type = stream
wait = no
server = /usr/local/sbin/popper qpopper -s
disable = no
}

Checked to see that popper was in the location and it was:

/etc]# ls -l /usr/local/sbin/popper
-rwxr-xr-x 1 root root 120980 Aug 14 16:49 /usr/local/sbin/popper

After reboot, nothing is listening to port 110:

/etc]# netstat -an | grep 110
/etc]#

Checked to see if other entries in /etc/xinetd.d were working:

/etc]# netstat -an | grep 80
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 66.112.33.128:80 218.65.222.47:25173 TIME_WAIT
tcp 0 0 66.112.33.128:80 217.39.170.167:3671 ESTABLISHED
tcp 0 0 66.112.33.128:80 68.7.212.146:4397 ESTABLISHED
tcp 0 0 66.112.33.128:80 68.7.212.146:4414 ESTABLISHED
tcp 0 0 66.112.33.128:80 68.7.212.146:4398 ESTABLISHED
/etc]#



Does anyone see anything I'm missing or made an error on. Many thinks in advance,
I've been working on this for two weeks now. !!
7 REPLIES
I_M
Honored Contributor

Re: Can't get pop-3 running.

Hi,

How about your current packet firewall settings?

# ipchains -L
or
# iptables -L

give you the info.

Try # telnet your-server 110 to see if the port is open or not.

Good luck

Re: Can't get pop-3 running.

I get connection refused when I try to telnet to port 110.

/root]# ipchains -L

Chain input (policy ACCEPT):
target prot opt source destination ports
ACCEPT udp ------ dns-lax.centurytel.net anywhere domain -> any
ACCEPT udp ------ dns-spt.centurytel.net anywhere domain -> any
ACCEPT udp ------ 90.0.0.1 anywhere domain -> any
ACCEPT tcp -y---- anywhere anywhere any -> pop3
ACCEPT tcp -y---- anywhere anywhere any -> smtp
ACCEPT tcp -y---- anywhere anywhere any -> http
ACCEPT tcp -y---- anywhere anywhere any -> ftp
ACCEPT tcp -y---- anywhere anywhere any -> telnet
ACCEPT udp ------ anywhere anywhere bootps:bootpc -> bootps:bootpc
ACCEPT udp ------ anywhere anywhere bootps:bootpc -> bootps:bootpc
ACCEPT all ------ anywhere anywhere n/a
REJECT tcp -y---- anywhere anywhere any -> 0:1023
REJECT tcp -y---- anywhere anywhere any -> nfs
REJECT udp ------ anywhere anywhere any -> 0:1023
REJECT udp ------ anywhere anywhere any -> nfs
REJECT tcp -y---- anywhere anywhere any -> x11:6009
REJECT tcp -y---- anywhere anywhere any -> xfs
Chain forward (policy DENY):
target prot opt source destination ports
MASQ all ------ anywhere anywhere n/a
Chain output (policy ACCEPT):


/root]# telnet localhost 110
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
/root]#
Bill Thorsteinson
Honored Contributor

Re: Can't get pop-3 running.

Does netstat -an show anything listening on port 110.
If not you may need to restart xinentd 'killall -HUP xinetd'.
Bill Thorsteinson
Honored Contributor

Re: Can't get pop-3 running.

Check /etc/hosts.allow and /etc/hosts.deny to make sure
the tcpwrappers is allowing access.

Re: Can't get pop-3 running.

Thanks for your help !

hosts.allow and hosts.deny are both empty contain only comments.

netstat -an returns nothing listening on port 110.

Restarted by rebooting. Still nothing on port 110.

What about the names pop3 or pop-3? I've tried various combinations of each but don't know what is the correct way to name the pop3 file in /etc/xinetd.d file.
Mark Fenton
Esteemed Contributor

Re: Can't get pop-3 running.

on my system (RH 7.3, sorry) the xinetd.d files are ipop3 and pop3s, the latter being for secure connection.

hth
Mark

Re: Can't get pop-3 running.

Thanks; I tried naming the file ipop3. Didn't work :(

Guess I'll have to bite the bullit and re-format and re-install.