General
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't login to hpsmh on sles9 amd64 hosts..

Mike Marion_1
Occasional Visitor

Can't login to hpsmh on sles9 amd64 hosts..

Have tried both 7.20 and 7.30 psp's rpms. Can connect to the host on port 2381 and get login form, but after entering data and hitting login, page never changes. Looking on host(s), hpsmhd error_log shows:

[Wed Jun 01 17:12:05 2005] [notice] CompaqHTTPServer/9.9 HP System Management Homepage/2.0.2.109 configured -- resuming normal operations
[Wed Jun 01 17:23:38 2005] [error] server reached MaxClients setting, consider raising the MaxClients setting
[Wed Jun 01 17:23:52 2005] [notice] child pid 27942 exit signal Segmentation fault (11)
[Wed Jun 01 17:23:54 2005] [notice] child pid 29443 exit signal Segmentation fault (11)

strace'ing the daemons shows that a child process is cloned, reads the group file, does a setuid to the hpsmh userid, then segfaults.

Haven't been able to login to the HPSystem Management agent on any of the SLES9 hosts lately to check on smartarray, or any other status.

Things are still reported to SIM host, but not being able to login to the individual agents is a pain.
3 REPLIES
Gopi Sekar
Honored Contributor

Re: Can't login to hpsmh on sles9 amd64 hosts..


I am running sles 9 x86 and i am able to login to port 2381 and see my system details.

have you customized your psp installation ? from the logs it looks like the MaxClients setting for httpd is set to low (or that many clients are already connected to it)

to increase the MaxClients limit, edit /opt/hp/hpsmh/conf/smhpd.conf file, locate the keyword 'MaxClients' it is by default set to 25, increase it to the limit you want.

Hope this helps,
Gopi
Never Never Never Giveup
Mike Marion_1
Occasional Visitor

Re: Can't login to hpsmh on sles9 amd64 hosts..

> to increase the MaxClients limit, edit
> /opt/hp/hpsmh/conf/smhpd.conf file, locate
> the keyword 'MaxClients' it is by default
> set to 25, increase it to the limit you
> want.

Actually, I tried that, and found it doesn't work. I even tried changing User to root for kicks.. and it turns out the start script (/opt/hp/hpsmh/sbin/smhstart) replaces that file if it's changed. Yep, stupid, but it does.. run strings on that binary and pipe to less, and you'll see the entire text of the default file in there. Don't know if it's an amd64 thing or not.
christian.soderlund
Occasional Visitor

Re: Can't login to hpsmh on sles9 amd64 hosts..

also tried to make a change in smhpd.conf but it restores the file to default when restarting the service.. not good.