General
cancel
Showing results for 
Search instead for 
Did you mean: 

Character set problem when sending mail to Exchange

SOLVED
Go to solution
Laurens Wagemakers
Occasional Visitor

Character set problem when sending mail to Exchange

Hi there,

I've configured our HP-Ux 10.20 system to use our Exchange Server to send mail. When the backup is ready it's mailed to the system administrator account. However when receiving a mail in Outlook the following message is printed and the original message is put in a attachement.

Message in Outlook>>>
This message was sent using a character set not unsupported on the Internet Mail Connector. The message text has been placed into the attachment: ATT00001.txt. To view, double-click on the attachment. If the text isn't displayed correctly, save the attachment to disk, and then use a viewer that can display the original character set.
<<<

Microsoft Technet has an article about this with PSS ID Number: Q157735 which states that charactersets like Roman-8, or starting with "X-..." are not supported.

I've tried to set the LANG variabele in the unix-shell to
other values, but nothing seems to help.

Does anybody know a way to connect HP-Ux to Exchange without the characterset problem ?
Book ??? = A pile of faxes
2 REPLIES
Kofi ARTHIABAH
Honored Contributor
Solution

Re: Character set problem when sending mail to Exchange

You can fix the problem by editting the file /usr/share/lib/mailx.rc and changing adding the line

set charset=us-ascii

Another way is to invoke mailx with the -m option. do a man mailx for details.
nothing wrong with me that a few lines of code cannot fix!
Victor BERRIDGE
Honored Contributor

Re: Character set problem when sending mail to Exchange

Hi,
You can alsoput environnment variables in file .mailrc (in home directory)

export charset=iso8859-1
export encoding=8bits

Regards
Victor