Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Clock ticking too fast

SOLVED
Go to solution
MRSG
Frequent Advisor

Clock ticking too fast

I have a HP Proliant DL360 G4p server running
RH4 2.6.9-5 EL x86_64 (64bit). It only has one Xeon 3.6Ghz CPU.

I'm experiancing a problem where the clock is ticking too fast (approx twice a second). I have tried adding "no_timer_check" and "noapic" to the grub.conf file and rebooting but to no avail.

I have the same kernel version on many 32bit machines but without the time issue. This is my only 64bit linux OS I have installed so far.

Does anyone know how to fix this problem? i'm pulling my hair out trying to resolve this and have resorted to adding an ntpdate command in cron to run every minute which is a very dirty quick fix which I don't like doing.

Any help would be much appreciated.

Thanks.

15 REPLIES
Ivan Ferreira
Honored Contributor

Re: Clock ticking too fast

We solved our problem using an external ntp source, like pool.ntp.org.

Configure your ntp.conf file to use these servers as time servers and start the ntp service, this is your best option instead of using ntpdate every minute.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Stuart Browne
Honored Contributor
Solution

Re: Clock ticking too fast

Umm, if it's a 64bit machine, then it's not a Xeon processor. It'll be an Opteron.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152170
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152630
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=153155

These are details about this bug. I believe if you browse around there, you'll find what you're after.

But in all honesty, I'd start by updating your kernel to the latest eratta.. You're on 2.6.9-5, when they've released 2.6.9-34!
One long-haired git at your service...
MRSG
Frequent Advisor

Re: Clock ticking too fast

I have tried syncing with ntpd but the clock is ticking too fast, which is why I have to set ntpdate.

Interesting that you say Opteron because a
# dmidecode shows Xeon. The chipset is EM64T but to be honest I get confused as to what is AMD and what is Intel nowadays.

An interesting thing is that my hwclock is showing the correct time so i've ran
hwclock --hctosys which sets the clock to the correct time but then races forward again.

I will look into updating the kernel but unfortunately I have limited downtime.
Stuart Browne
Honored Contributor

Re: Clock ticking too fast

I'm sure you can see that this is a most necessary update.

What does /proc/cpuinfo say?
One long-haired git at your service...
Manuel Wolfshant
Trusted Contributor

Re: Clock ticking too fast

The adequate kernels for Xeon based computers are SMP / IA64, not x86_64. Last ones are optimized for AMD processors (Opteron/Athlon64), while the IA64 ones have Xeon/Itanium as targets.
In your case, I think that you should use either kernel-smp-2.6.9-34.EL.i686.rpm or kernel-2.6.9-34.EL.ia64.rpm.

The SMP part is useful because of the hyper threading technology included in Xeon: linux will see each HT enabled processor as TWO processors instead of only one (hence the ability to run two tasks in parallel, provided you have a SMP enabled kernel). Upon successfull boot, you will have in /var/log/messages something similar to:
CPU#1: Intel P4/Xeon Extended MCE MSRs (12) available
CPU#1: Thermal monitoring enabled
CPU1: Intel(R) Xeon(TM) CPU 2.60GHz stepping 07
Total of 2 processors activated (10289.15 BogoMIPS).

MRSG
Frequent Advisor

Re: Clock ticking too fast

Thank you all for supplying me with much needed info.

I will be updating to the lastest errata using the Up2Date service. Hopefully this will resolve the problem (i'm crossing my fingers).

I am still slightly confused with the SMP HT configurations. I do have HT enabled thru the bios and I only have 1 CPU. Does this mean I need to boot into an SMP kernel? I do have the kernel installed but have been using the EL version. My thinking was that the clock was ticking for 2 CPUs however i'm now thinking this was a red herring on my part.

7 years as a hpux admin and only 3 months on linux i'm afraid.
Stuart Browne
Honored Contributor

Re: Clock ticking too fast

HT presents it's self to the Linux kernel as two (virtual) processors, so using an SMP kernel would be good.

The reference as to what CPU you've got however is still worrying me.

All the documentation I can find says that the DL360 G4p has an 'Intel Xeon' processor in it. If this is the case, using the x86_64 install is *VERY*VERY* wrong.

If, however, I'm just bad at finding documentation, and it does infact have an 'AMD Opteron' or other EM64 processor, then you've got the right install.

What do the contents of '/proc/cpuinfo' say?

It should have a line that says either:

model name : AMD Opteron (tm) Processor
(-- x86_64 happy, 64bit --)
or:

model name : Intel(R) Xeon(TM) CPU 3.60GHz
(-- i386/i686 happy, 32bit --)
One long-haired git at your service...
Manuel Wolfshant
Trusted Contributor

Re: Clock ticking too fast

>I will be updating to the lastest errata
excellent choice. If the problem is not solved (and none of the boot time options like notsc / noapic -- see bugzilla for details -- solve it) please fill a bug on https://bugzilla.redhat.com


>I am still slightly confused with the SMP HT configurations. I do have HT enabled thru the bios and I only have 1 CPU. Does this mean I need to boot into an SMP kernel?
YES.

>I do have the kernel installed but have been using the EL version.
All RH kernels have EL in their name. I guess it's a shortcut from RHEL or smtg

> My thinking was that the clock was ticking for 2 CPUs
No, it's a bug. Please see the bugzilla entries highlighted by Stuart.

>7 years as a hpux admin and only 3 months on linux i'm afraid.
I am using linux since '95 and I am still learning each day.So.. welcome to the club :)
MRSG
Frequent Advisor

Re: Clock ticking too fast

Ok,

I have rebooted into the smp kernel. This was because a developer was having problems with code he had already written. Therefore here is some more info see attahed notepad doc.
uname gives the following:

2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:29:47 EST 2005 x86_64 x86_64 x86_64 GNU/Linux

Is the above install correct for my chipset? There is only 1 CPU in this server but cpuinfo is saying two.

Many thanks for all your help.


Manuel Wolfshant
Trusted Contributor

Re: Clock ticking too fast

Yes, this is exactly as it should be. As we have said before, HT enabled processors are seen as two [identical] processors, each one being able to be used separately of the other. The kernel takes care of balancing the tasks among all existing "virtual" processors.

But updating to latest Errata is still a good idea...
MRSG
Frequent Advisor

Re: Clock ticking too fast

Yes I think you are right and I will update to the latest errata. However I am a bit concerned that my CPU is an intel Xeon 3.6 EM64T running x86_64 which, if Stuart and Manuel are correct, is the wrong 64bit version.

Unfortunatley I didn't install this and have just been passed the time problem. I seem to be opening a can of worms :) Is there any info I can get to give me the correct type of linux kernel I should be using with my chipset? I can't seem to find much on RedHat.

Once again thank you all for helping me in my hour of need.
Manuel Wolfshant
Trusted Contributor

Re: Clock ticking too fast

MRSG
Frequent Advisor

Re: Clock ticking too fast

I should have mentioned i'm running RHEL4. However using a simliar search from your post I was able to find the document albeit for RHEL 4 and have extracted this bit of info:

Unlike earlier releases, Red Hat Enterprise Linux 4 kernel support for Intel® Extended Memory 64 Technology (hereafter referred to as "Intel® EM64T"), and AMD64 processors exist in a single "x86-64" kernel. There are no longer separate kernels for each processor type

I'm thinking I do have the correct kernel for my chipset. I'm am going to sort out the errata update.

Thanks.
Stuart Browne
Honored Contributor

Re: Clock ticking too fast

Hrm, no, it's the right version.. I hadn't seen one of the newer series of Xeon's.
One long-haired git at your service...
MRSG
Frequent Advisor

Re: Clock ticking too fast

Gonna have to get some downtime to update the kernel. I will close this thread and if the problem still exists after the update I will raise a call with RH.

Many thanks to all those who helped.