Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting to Internet via PCMCIA Modem card

Pierre M. Camilleri
Frequent Advisor

Connecting to Internet via PCMCIA Modem card

Hi Everyone

I've recently installed RH Linux 7.2 onto a Compaq Armada which has a PCMCIA network and modem card (2 in 1) installed.
The PCMCIA card services seem to be working properly as I get two beeps upon powering the notebook. I've created a dial up connection using the RH configuration (wizard) utility and when I clicked on the debug in order to test the connection I got a DialTone not detected. My problem is this. How can I edit the modem script so that my PCMCIA modem will detect a dialtone? Or what else must be done. The wizard detected my modem as ttys3
Any help would be much appreciated.

TIA
Pierre
2 REPLIES
Marcin Golembski_1
Honored Contributor

Re: Connecting to Internet via PCMCIA Modem card

RH used to have problems with such combo cards, usually the network part works OK but modem, even though correctly detected, not. So first verify if the modem really works. I use minicom for this (a console comm proggie). Make minicom use ttyS3 and the correct baud rate (usually 115200bps works fine for PCMCIA modems), parity, stop bits etc. Then issue an AT command in the minicom window - the modem should respond with 'OK'. If it does, then the script may indeed be broken.

If the modem does not respond with 'OK' (or you don't even see 'AT' echoed on the screen) then the problem most probably lies in the kernel or the modem's pcmcia driver. My approach is to use the kernel from ftp.kernel.org, not from the distribution (and RH is known for changing the original kernel), and the separate, latest pcmcia_cs package. When I configure the new kernel (BTW, it's a good idea to customize the kernel for the machine it is run on, to get rid of all those never used drivers) I disable the built-in pcmcia support (if we're talking 2.4.x kernels) so it does not conflict with pcmcia_cs. The critical thing is to enable IRQ sharing for serial devices (CONFIG_SERIAL_SHARE_IRQ) - I could not make the modem part of my Xircom lan/modem combo card work with this setting disabled. I recommend reading PCMCIA-HOWTO - it contains a lot of useful information about installation, configuration and troubleshooting of pcmcia.

HTH (and not too many parentheses ;-)
Marcin
Peter Gathercole
Occasional Visitor

Re: Connecting to Internet via PCMCIA Modem card

This could have nothing to do with the PCMCIA element of this. It may just be that the modem is not recognising the dialtone.

This can be if you have either a non-standard dialtone frequency (for example if you are going through a PABX), or you have got subscriber services that modify the dialtone (like making it a broken dial tone).

You can get most modems to ignore the wait for dialtone. This is done by putting the X3 command somewhere in the modem setup or dial string for the modem. Unfortunatly, I do not know how to break in to the modem strings in the RedHat Internet Dialer. I can in KPPP by adding it to the string to set the speaker volume.

Perhaps someone else can provide more information here.