Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Connection Problem via serial interface

SOLVED
Go to solution
Hicham EL HARTI
Occasional Contributor

Connection Problem via serial interface

I have a problem connecting a HP Proliant Server DL320 (also DL380, DL560 and DL580)via the serial interface with my laptop. The OS installed on it is Linux SuSe.
The output of the command stty -a is:
=============================================
speed 38400 baud; rows 24; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = ;
eol2 = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc -ixany imaxbel
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke
=============================================

The hyperterminal connection (TeraTerm)on my laptop is configured as:
BAUD rate: 38400
Bist per Character: 8
Parity: None
Stop Bits: 1
Flow Control: None

I also tried 9600Baud 8N1N configuration but no success.

The cable should be OK, because I used it with other HP machines and it worked.

Can somebody tell me please what is wrong?

Thanks!
2 REPLIES
Muthukumar_5
Honored Contributor

Re: Connection Problem via serial interface

what you are getting on console as errors or warnings? Are you able to ping the ip-address of that serial interface? Check the connectivity before debugging problem more.

-Muthu
Easy to suggest when don't know about the problem!
Sergejs Svitnevs
Honored Contributor
Solution

Re: Connection Problem via serial interface

You must tell linux to redirect its console to the serial port. Add to /etc/inittab:

T0:23:respawn:/sbin/getty -L ttyS0 38400 vt100

then execute "init q" and try again.

Regards,
Sergejs