cancel
Showing results for 
Search instead for 
Did you mean: 

D510 e-PC

Robert_306
Occasional Visitor

D510 e-PC

Has anyone ever succesfully installed LINUX or UNIX of any flavor on one of these? I have the need to make a UNIX workstation out of one, and FreeBSD, Red Hat, Fedora, White Hat, OpenBSD, etc all fail to boot. Grub hangs at the "Loading stage 2" and LILO only gets the "LI" on the screen before it hangs. BSD kernels won't even boot the thing at all.

The D530 line works fantastic but I need to get some of these D510's up and running on ANY UNIX flavor that's semi-modern. I see that it supports both SUSE and Mandrake, but obviously those can't be used as they are lawsuit traps not Operating Systems.

Please, anyone, any flavor, I don't care at all, as long as it's free-ish, boots from the hard drive, and POSIX compliant with an X-Windows interface. Pretty minimal standards.

I can't believe that 4,000 flavors of MS Windows run on them but 0 flavors of UNIX.
9 REPLIES
Steven E. Protter
Exalted Contributor

Re: D510 e-PC

Try using grub as the boot manager. It is the "replacement" to LILO and can handle some of the quirkier machines.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Fabio Ettore
Honored Contributor

Re: D510 e-PC

Hi Robert,

a few days ago I installed Linux Fedora 2.0 on the same PC model, Compaq D510 e-pc.
I use it for any tests.
It is alongside me and works very well, I never had problems with it.

HTH.

Best regards,
Fabio

WISH? IMPROVEMENT!
Jerome Henry
Honored Contributor

Re: D510 e-PC

Grub hanging at stage 2 and LI means that the loaders can't find root (/boot) partition as read from the MBR.
Most of the time, it's because :
- the bios can't adress a /boot located farther than 2 GB. You should create a partition for /boot at the very beginning of the disk ;
- The disk has a special driver to be accessed, the bios transmits successfully to the MBR but then the loader can't do it... once again back to the bios, check that it transmits that your Hard disk is seen as Large or LBA ...

hth

J
You can lean only on what resists you...
Robert_306
Occasional Visitor

Re: D510 e-PC

Thanks for the quick replies!

1) I did try GRUB first, and LILO after that failed by booting to the rescue kernel off CD-Rom and installing LILO off disk 3 of Fedora Core 2. Both fail at what looks like the same spot.

2) Yes it helps a LOT to know that you have FC2 up and running on this box. I need to know the "magic" that you did to accomplish this.

What size HDD / HDD configuration do you have? I have tons of these boxes. Some are 20GB some are 40GB. Some of the BIOS' report that the drive is LBA some report that LBA is off. If you know the "BIOS" of these systems you know that there's really no settable options. I've tried it on both the LBA and non LBA 40GB drives. Should I be focusing on the 20GB drive version?

Mind exchanging e-mail addresses or something to do a little back and forth on troubleshooting this? The fact that you got it working first time and I can't get any of 10 flavors of UNIX to load on 5 of these things makes me think there's something VERY simple and obvious that I missed in the BIOS or the config.

3) This sounds exactly like the problem, BUT I let all the LINUX' auto-format the drives, and it made a /boot at 100MB that looks like it's the first partition, so it's within the 2 GB limit.

The system made a 100 MB /boot, a 40 GB /, and a 500MB /swap (not 100% certain about the swap size).
Robert_306
Occasional Visitor

Re: D510 e-PC

I tried to install FC2 on a 20GB HDD model (those run at 2.0Ghz, not 2.4 Ghz) and this time it doesn't even hang at "Grub Loading Stage 2" it says "Grub" and freezed before it can finish loading the line.

Did you use a special Italian localized distro of FC2?
Robert_306
Occasional Visitor

Re: D510 e-PC

Fabio, does your D510 say the hard drive is LBA? Mine says "LBA NO", I swapped it with one that said "LBA LBA" and now it's reporting "LBA NO" in the BIOS summary screen, but there's no way to update the BIOS.
Richard Wilson_4
Occasional Visitor

Re: D510 e-PC

I am also trying to install a not windows operating system on my Evo. I found that if I loaded lilo with for following command it got me a little further. /sbin/lilo -l I hope this help. but it really does not get me anywhere it hangs after extracting the kernel
Ursus
Occasional Visitor

Re: D510 e-PC

Hallo everyone from this thread,

now it's up to me to try and install a linux (preferrably gentoo) onto such a "suspicious" minidesktop.

As this thread seems a little "cold" maybe either there is a solution found in between or everyone accepts the fact that these boxes are linux-resistant.

So here my question. grub stops after:

GRUB loading stage 1.5
GRUB loading, please wait...

whatever I tried the last days.

All I learned from google is that it has to do something with the harddisk's geometry-settings which seem unavailable in the d510e-pc's bios.

Does anybody think there might be a way out of this disastrous situation ... ?

Thanks a lot

Joe
Alex Gusev
Occasional Visitor

Re: D510 e-PC

I did it!

You need to change Grub with Lilo, than it works.

Cookbook is here:
http://www.fedoraforum.org/forum/showthread.php?t=115515