General
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360 G4 Fedora Core 3 Problems

Curt LeCaptain
Occasional Visitor

DL360 G4 Fedora Core 3 Problems

Installation went fine, it recognized the network card, the SmartArray6i controller, all went well. Then I attempted to boot for the first time, and the system hung on "Booting from Hard Disk (C:)". All is well with the RBSU, I set that up to make sure the system attempted a hard disk boot off of the 6i controller. What am I missing here?
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: DL360 G4 Fedora Core 3 Problems

These servers have a specific by model disk preparation cd. You have to boot off the cd and prepare the disk, then install FC3. Did you do the disk prep?

I've found FC2 quite a bit more reliable than FC3. Some hardware that worked well with FC2 crashes the install kernel of FC3.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Curt LeCaptain
Occasional Visitor

Re: DL360 G4 Fedora Core 3 Problems

I would go with that, except for one thing, the Proliant boot CD is for Win 2K/2003/Novell, not for Linux.
Ivajlo Yanakiev
Respected Contributor

Re: DL360 G4 Fedora Core 3 Problems

This is problem with your boot loader
This are problem with FC 3 and GRUB

Install again GRUB or replace GRUB with LILO.

Also make sure that your boot order include DISK.


Brad Clemmons
Occasional Visitor

Re: DL360 G4 Fedora Core 3 Problems

I ran into this problem with FC3 on a DL360 G3 with SmartArray 5i. The bootloader never got installed properly. This is how i solved it. You need to boot off of the Fedora Rescue CD.
Once at a shell prompt:
chroot /mnt/sysimage
grub-install /dev/cciss/c0d0
now type exit and let it reboot itself -all should start now.

-Brad
Carl_92
Occasional Visitor

Re: DL360 G4 Fedora Core 3 Problems

I have the exact same problem with FC3 on the DL360G4. I didn't find anything on preparing disks on the CD that was included in the box and besides that, why would i have to do that? The array controller initialises the array, what more initializing could need be done!?

However it worked to boot rescue from the Fedora install disk and reinstall grub like told above. A pity though, since i've made kickstart and bootable CD so i don't have to touch the keyboard at all when installing other non HP servers.

But then again, HP only seem to support O/Ss you have to pay for.
Gopi Sekar
Honored Contributor

Re: DL360 G4 Fedora Core 3 Problems

looks like boot loader is not installed properly...

try booting through FC rescue CD and re run grub/lilo boot loader again manually and see whether it brings up the system.

Never Never Never Giveup