cancel
Showing results for 
Search instead for 
Did you mean: 

Data portability

Thayanidhi
Honored Contributor

Data portability

Hi

Can I read a tape(DDS) created in unix, in to a NT/2000 system. Is there any utility in unix
or in NT/2000 to make this straight. The requirment is to transfer a huge (more than 1GB) oracle export dump from unix to NT.

I tried ftp, but failed because ftp doesn't allow more than 500MB!(correct me if I am wrong). Is there any other way to transfer the file?

Thanks in advance.

T.Thayanidhi
Attitude (not aptitude) determines altitude.
4 REPLIES
RAC_1
Honored Contributor

Re: Data portability

If the export dump is on tape you can not get it on NT.(As far I know)

You can copy it to a partition on unix box with dd command then split it into the chunks of 250 MB or so and then get it on NT.

Second way do you have samba/CIFS.

You can copy that dump from unix partition to NT

Regards,
There is no substitute to HARDWORK
Thayanidhi
Honored Contributor

Re: Data portability

CIFS or NFS may work! Is there any other alternate. What is command and syntax to split the file. After transfering how to merge back?

T.Thayanidhi
Attitude (not aptitude) determines altitude.
RAC_1
Honored Contributor

Re: Data portability

I doubt I missed something. Split might not be compatible with NT. (You might get split that works on both NT & unix on net) At the moment you can leave this aside.

Can you check with compress you_dump_file.
Try gzip, compact etc.

Check the size.)Hope it goes bellow 500 MB)
Then you can do ftp.

And can open it with winzip also.

This is lengthy exercise.

Do you have omniback? that could have worked by restoring the backup on NT.

Just try .(CIFS,Samba are also lengthy)

Regards,
There is no substitute to HARDWORK
Jon Finley
Honored Contributor

Re: Data portability

Sounds like you may have hit a ulimit on the HP system.

You can issue ulimit -a to check the settings.

File SHOULD be set at unlimited. This can be changed by issueing: ulimit -f unlimited

You can also insert ulimit -f unlimited into /etc/profile to take affect at the next boot.


From HP:
----------------
The default ulimit should be the maximum values. If they are not, then a
process or script has lowered it. Changes in the ulimit can be caused by the
daemon that is logging you in (telnetd, inetd, sshd, getty, uugetty), any
startup scripts (/etc/profile, .profile, .login) or scripts that are called by
a startup script. Cron and at jobs can also be affected.


Things to try that will direct you to the problem...
-Put ulimit -a as the first line in the /etc/profile.
-Is it different then what you would normally get at a shell prompt.
-Never test using su or login command.
-Always test using "telnet localhost" or "rlogin localhost".
-Is the ulimit different for root and non-root users
-Is the ulimit different for telnet & console logins
-Disable tcp wrappers
-Disable 3rd party security software.
-Disable 3rd party login daemons (sshd, 3rd party ftpd or telnetd)

------------------

Jon
"Do or do not. There is no try!" - Yoda