cancel
Showing results for 
Search instead for 
Did you mean: 

Debian Etch and Lenny

Semlali_1
Advisor

Debian Etch and Lenny

I have tow Desktop HP (HP Compaq 6000 Pro, HP Compaq 8000 Elite) When i try to install Linux Debian (Lenny or Etch) The système can't find the network drivers.
Can you help me to install this desktop with Linux Debian ?

Thanks
4 REPLIES
Daniel Frazier
Frequent Advisor

Re: Debian Etch and Lenny

It looks like you might need a bnx2 driver - do you get prompted for firmware files when installing lenny? If so, see:

http://wiki.debian.org/HP/ProLiant#Needbnx2firmware

If that doesn't help, you might try dropping to a shell (option in the installer) and providing the output of 'lspci' and 'lspci -n'
Semlali_1
Advisor

Re: Debian Etch and Lenny

his is the result of command lspci -n with Debian testing, but i always have the same probléme with Debian Lenny and Etch, i can't install the paquet pciutils, because my network card dosnt work

root@Debian:~# lspci -n
00:00.0 0600: 8086:2e10 (rev 03)
00:02.0 0300: 8086:2e12 (rev 03)
00:02.1 0380: 8086:2e13 (rev 03)
00:03.0 0780: 8086:2e14 (rev 03)
00:03.2 0101: 8086:2e16 (rev 03)
00:03.3 0700: 8086:2e17 (rev 03)
00:19.0 0200: 8086:10de (rev 02)
00:1a.0 0c03: 8086:3a67 (rev 02)
00:1a.1 0c03: 8086:3a68 (rev 02)
00:1a.2 0c03: 8086:3a69 (rev 02)
00:1a.7 0c03: 8086:3a6c (rev 02)
00:1b.0 0403: 8086:3a6e (rev 02)
00:1c.0 0604: 8086:3a70 (rev 02)
00:1c.1 0604: 8086:3a72 (rev 02)
00:1d.0 0c03: 8086:3a64 (rev 02)
00:1d.1 0c03: 8086:3a65 (rev 02)
00:1d.2 0c03: 8086:3a66 (rev 02)
00:1d.7 0c03: 8086:3a6a (rev 02)
00:1e.0 0604: 8086:244e (rev a2)
00:1f.0 0601: 8086:3a14 (rev 02)
00:1f.2 0106: 8086:3a02 (rev 02)
root@Debian:~#
Thanks
Daniel Frazier
Frequent Advisor

Re: Debian Etch and Lenny

Looks like support for this chip got added in 2.6.28 - Debian lenny is based on 2.6.26.

You could file a bug (severity important) request this backport to 2.6.26. You can also safely run the testing kernel in a lenny environment.

commit f4187b56e1f8a05dd110875d5094b21b51ebd79b
Author: Bruce Allan
Date: Tue Aug 26 18:36:50 2008 -0700

e1000e: add support for 82567LM-3 and 82567LF-3 (ICH10D) parts

Add support for new LOM devices on the latest generation ICHx platforms.

Signed-off-by: Bruce Allan
Signed-off-by: Jeff Kirsher
Signed-off-by: Jeff Garzik
Goran Koruga
Honored Contributor

Re: Debian Etch and Lenny

Hello.

Use "kmuto" lenny installer with 2.6.32 kernel:

http://kmuto.jp/debian/d-i/

Regards,
Goran